Opened 7 years ago

Closed 6 years ago

#1997 closed defect (fixed)

regression failures under windows 9.2 64-bit release

Reported by: robe Owned by: robe
Priority: critical Milestone: PostGIS 2.1.0
Component: postgis Version: trunk
Keywords: Cc:

Description

I have to verify if same issue on my regular 32-bit chain but on mingw64 my 9.2 is showing this, but might be something amiss with my compilation or something since I recently built 9.2 release.

 loader/Point .............. ok 
 loader/PointM .............. ok 
 loader/PointZ .............. ok 
 loader/MultiPoint .............. ok 
 loader/MultiPointM .............. ok 
 loader/MultiPointZ .............. ok 
 loader/Arc .............. ok 
 loader/ArcM .............. ok 
 loader/ArcZ .............. ok 
 loader/Polygon .............. ok 
 loader/PolygonM .............. ok 
 loader/PolygonZ .............. ok 
 loader/TSTPolygon ......... ok 
 loader/TSIPolygon ......... ok 
 loader/TSTIPolygon ......... ok 
 loader/PointWithSchema ..... ok 
 loader/NoTransPoint ......... ok 
 loader/NotReallyMultiPoint ......... ok 
 loader/MultiToSinglePoint ......... ok 
 loader/ReprojectPts ........ ok 
 loader/ReprojectPtsGeog ........ ok 
 loader/Latin1 .... ok 
 binary .. ok 
 regress .. failed (diff expected obtained: /tmp/pgis_reg/test_24_diff)
 regress_index .. failed (diff expected obtained: /tmp/pgis_reg/test_25_diff)
 regress_index_nulls .. failed (diff expected obtained: /tmp/pgis_reg/test_26_diff)
 lwgeom_regress .. ok 
 regress_lrs .. ok 
 removepoint .. ok 
 setpoint .. ok 
 simplify .. ok 
 snaptogrid .. ok 
 summary .. ok 
 affine .. ok 
 empty .. ok 
 measures .. ok 
 legacy .. failed (diff expected obtained: /tmp/pgis_reg/test_37_diff)
 long_xact .. ok 
 ctors .. ok 
 sql-mm-serialize .. ok 
 sql-mm-circularstring .. ok 
 sql-mm-compoundcurve .. ok 
 sql-mm-curvepoly .. ok 
 sql-mm-general .. ok 
 sql-mm-multicurve .. ok 
 sql-mm-multisurface .. ok 
 polyhedralsurface .. ok 
 polygonize .. ok 
 postgis_type_name .. ok 
 geography .. ok 
 out_geometry .. ok 
 out_geography .. ok 
 in_gml .. ok 
 in_kml .. ok 
 iscollection .. ok 
 regress_ogc .. ok 
 regress_ogc_cover .. ok 
 regress_ogc_prep .. ok 
 regress_bdpoly .. ok 
 regress_proj .. ok 
 regress_management .. failed (diff expected obtained: /tmp/pgis_reg/test_61_diff)
 dump .. ok 
 dumppoints .. ok 
 wmsservers .. ok 
 wkt .. ok 
 wkb .. ok 
 tickets .. ok 
 typmod .. failed (diff expected obtained: /tmp/pgis_reg/test_68_diff)
 remove_repeated_points .. ok 
 split .. ok 
 relate .. ok 
 bestsrid .. ok 
 concave_hull .. ok 
 hausdorff .. ok 
 regress_buffer_params .. ok 
 offsetcurve .. failed (diff expected obtained: /tmp/pgis_reg/test_76_diff)
 relatematch .. ok 
 isvaliddetail .. ok 
 sharedpaths .. ok 
 snap .. ok 
 node .. ok 
 unaryunion .. ok 
 clean .. ok 
 relate_bnr .. ok 
 delaunaytriangles .. ok 
 in_geojson .. ok 
 uninstall .

Winnie 9.1 x64 bit is passing tests fine.

I've ruled out 9.2 as primary culprit since Debbie is passing with flying colors and she's running 9.2 release version too.

Change History (9)

comment:1 Changed 7 years ago by robe

Resolution: invalid
Status: newclosed

I think I may have been missing iconv or something path settings. My 9.2 32-bit is going thru okay after I copied. Still need to check my 64-bit, but I'm guessing it is the same issue

comment:2 Changed 7 years ago by robe

Milestone: PostGIS 2.1.0PostGIS 2.0.2
Resolution: invalid
Status: closedreopened

Okay something else wrong here. Winnie is doing fine on regressing 32-bit 9.2 but coughing with regressing the 9.2 64bit. idon't recall this issue with the rc1s.

Inspection of failures, are crashes of the backend. I'm having similar issue with building the 2.0.1 64-bit for 9.2 on my windows 7 64-bit. The annoying thing is if I run the statements manually that cause the crash, they don't crash.

comment:3 Changed 7 years ago by robe

Owner: changed from pramsey to robe
Status: reopenednew

comment:4 Changed 7 years ago by robe

Component: postgisbuild/upgrade/install

comment:5 Changed 7 years ago by robe

Okay seems to be some sort of memory leak or something.

An example that crashes the service (only my 64-bit the 32-bit seems fine)

If I run this statement 3-4 times on the 3rd to 4th time it crashes the service

select '165', ST_AsEWKT('POLYGON((0 0 0, 1 0 0, 1 1 0, 0 1 0, 0 0.1 1))');

I don't recall having this issue when testing Pg9.2rc1, so this may be a new development.

comment:6 Changed 7 years ago by robe

Component: build/upgrade/installpostgis

comment:7 Changed 7 years ago by robe

Seems to be something to do with error handling as it only crashes for the error handler regress ones.

Why I don't have issue with 9.1x64bit EDB is a bit puzzling.

comment:8 Changed 7 years ago by robe

Milestone: PostGIS 2.0.2PostGIS 2.1.0

I think this is a winnie only issue. I think my windows 7 mingw is fine for 9.2. So I'm going to push this since it's probably a config issue and not code.

comment:9 Changed 6 years ago by robe

Resolution: fixed
Status: newclosed

this hasn't happened in a while even on winnie.

Note: See TracTickets for help on using tickets.