Opened 7 years ago

Closed 7 years ago

#1963 closed defect (fixed)

regress failure on pgsql regress test caused by ST_Segmentize

Reported by: robe Owned by: pramsey
Priority: blocker Milestone: PostGIS 2.1.0
Component: postgis Version: trunk
Keywords: Cc:

Description

Just noticed my windows buildbot has been failing on regress test for the past day or so

  
  PostGIS is now configured for i686-w64-mingw32

 -------------- Compiler Info ------------- 
  C compiler:           i686-w64-mingw32-gcc -g -O2
  C++ compiler:         i686-w64-mingw32-g++ -g -O2
  SQL preprocessor:     /mingw/bin/cpp -traditional-cpp -P

 -------------- Dependencies -------------- 
  GEOS config:          /c/jenkins/geos/rel-3.4.0devw32/bin/geos-config
  GEOS version:         3.4.0dev
  GDAL config:          /c/jenkins/gdal/rel-1.9.1w32/bin/gdal-config
  GDAL version:         1.9.1
  PostgreSQL config:    /c/jenkins/postgresql/rel/pg9.2beta2w32/bin/pg_config
  PostgreSQL version:   PostgreSQL 9.2beta2
  PROJ4 version:        48
  Libxml2 config:       /c/ming32/projects/libxml/rel-libxml2-2.7.8w32/bin/xml2-config
  Libxml2 version:      2.7.8
  JSON-C support:       yes
  PostGIS debug level:  0
  Perl:                 /bin/perl

 --------------- Extensions --------------- 
  PostGIS Raster:       enabled
  PostGIS Topology:     enabled

 -------- Documentation Generation -------- 
  xsltproc:             /c/ming32/projects/xsltproc/xsltproc
  xsl style sheets:     /c/ming32/projects/docbook/docbook-xsl-1.76.1
  dblatex:              
  convert:              /c/Windows/system32/convert
  mathml2.dtd:          http://www.w3.org/Math/DTD/mathml2/mathml2.dtd

     CUnit - A unit testing framework for C - Version 2.1-2
     http://cunit.sourceforge.net/


PostgreSQL 9.2beta2 on i686-w64-mingw32, compiled by i686-w64-mingw32-gcc.exe (GCC) 4.5.4 20111030 (prerelease) [svn/rev.180676 - mingw-w64/oz], 32-bit
  Postgis 2.1.0SVN
 - r10195
 - 2012-08-22 22:06:20
  GEOS: 3.4.0dev-CAPI-1.8.0 r0
  PROJ: Rel. 4.8.0, 6 March 2012

Running tests

 loader/Point .............. ok 
 loader/PointM .............. ok 
 loader/PointZ .............. ok 
 loader/MultiPoint .............. ok 
 loader/MultiPointM .............. ok 
 loader/MultiPointZ .............. ok 
 loader/Arc .............. ok 
 loader/ArcM .............. ok 
 loader/ArcZ .............. ok 
 loader/Polygon .............. ok 
 loader/PolygonM .............. ok 
 loader/PolygonZ .............. ok 
 loader/TSTPolygon ......... ok 
 loader/TSIPolygon ......... ok 
 loader/TSTIPolygon ......... ok 
 loader/PointWithSchema ..... ok 
 loader/NoTransPoint ......... ok 
 loader/NotReallyMultiPoint ......... ok 
 loader/MultiToSinglePoint ......... ok 
 loader/ReprojectPts ........ ok 
 loader/ReprojectPtsGeog ........ ok 
 loader/Latin1 .... ok 
 binary .. ok 
 regress .. failed (diff expected obtained: /tmp/pgis_reg/test_24_diff)
 regress_index .. ok 
 regress_index_nulls .. ok 
 lwgeom_regress .. ok 
 regress_lrs .. ok 
 removepoint .. ok 
 setpoint .. ok 
 simplify .. ok 
 snaptogrid .. ok 
 summary .. ok 
 affine .. ok 
 empty .. ok 
 measures .. ok 
 legacy .. ok 
 long_xact .. ok 
 ctors .. ok 
 sql-mm-serialize .. ok 
 sql-mm-circularstring .. ok 
 sql-mm-compoundcurve .. ok 
 sql-mm-curvepoly .. ok 
 sql-mm-general .. ok 
 sql-mm-multicurve .. ok 
 sql-mm-multisurface .. ok 
 polyhedralsurface .. ok 
 polygonize .. ok 
 postgis_type_name .. ok 
 geography .. ok 
 out_geometry .. ok 
 out_geography .. ok 
 in_gml .. ok 
 in_kml .. ok 
 iscollection .. ok 
 regress_ogc .. ok 
 regress_ogc_cover .. ok 
 regress_ogc_prep .. ok 
 regress_bdpoly .. ok 
 regress_proj .. ok 
 regress_management .. ok 
 dump .. ok 
 dumppoints .. ok 
 wmsservers .. ok 
 wkt .. ok 
 wkb .. ok 
 tickets .. ok 
 typmod .. ok 
 remove_repeated_points .. ok 
 split .. ok 
 relate .. ok 
 bestsrid .. ok 
 concave_hull .. ok 
 hausdorff .. ok 
 regress_buffer_params .. ok 
 offsetcurve .. ok 
 relatematch .. ok 
 isvaliddetail .. ok 
 sharedpaths .. ok 
 snap .. ok 
 node .. ok 
 unaryunion .. ok 
 clean .. ok 
 relate_bnr .. ok 
 delaunaytriangles .. ok 
 in_geojson .. ok 
 uninstall .. ok (4061
)

Run tests: 87
Failed: 1

above is from 9.2, but I think 9.1 and 9.0 are failing as well. I'll look at the diff in a bit.

Change History (2)

comment:1 Changed 7 years ago by robe

Here is the error:

154.OBT: 148|LINESTRING(0 0,5 0,10 0)
154.EXP: ERROR:  function st_segmentize(unknown, integer) is not unique at character 25
155.OBT: 149|GEOMETRYCOLLECTION EMPTY
155.EXP: ERROR:  function st_segmentize(unknown, numeric) is not unique at character 25

comment:2 Changed 7 years ago by robe

Resolution: fixed
Status: newclosed
Summary: Windows buildbot regress failure on pgsql regress testregress failure on pgsql regress test caused by ST_Segmentize

Introduction of ST_Segmentize(geography,numeric) I suspect is the culprit here, so revised the regress.sql to accomodate

Should be fixed at r10198

Note: See TracTickets for help on using tickets.