Opened 7 years ago

Closed 7 years ago

#1954 closed defect (invalid)

Test failures in 1.5 branch (includes crashes!)

Reported by: strk Owned by: pramsey
Priority: critical Milestone: PostGIS 1.5.5
Component: postgis Version: 1.5.X
Keywords: Cc:

Description

As of r10085, after manually wiping out all .o .a and .so files, this is the result of make clean && ./autogen.sh && ./configure && make && make check :

*** regress_ogc_prep_expected   Tue May 22 11:16:14 2012
--- /tmp/pgis_reg_18825/test_45_out     Fri Aug 17 12:00:10 2012
***************
*** 4,21 ****
  intersects102|f
  intersects103|t
  intersects104|f
! contains099|t
! contains100|t
! contains101|f
! contains102|f
! contains103|f
! contains104|f
! covers099|t
! covers100|t
! covers101|t
! covers102|f
! covers103|t
! covers104|f
  containsproperly099|t
  containsproperly100|t
  containsproperly101|f
--- 4,11 ----
  intersects102|f
  intersects103|t
  intersects104|f
! ERROR:  lwgeom_size called with unknown-typed serialized geometry
! ERROR:  lwgeom_size called with unknown-typed serialized geometry
  containsproperly099|t
  containsproperly100|t
  containsproperly101|f
***************
*** 34,42 ****
  intersects108|f
  intersects108|f
  intersects108|f
! contains105|t
! contains105|t
! contains105|t
  contains106|f
  contains106|f
  contains106|f
--- 24,30 ----
  intersects108|f
  intersects108|f
  intersects108|f
! ERROR:  lwgeom_size called with unknown-typed serialized geometry
  contains106|f
  contains106|f
  contains106|f
***************
*** 58,66 ****
  containsproperly108|f
  containsproperly108|f
  containsproperly108|f
! covers105|t
! covers105|t
! covers105|t
  covers106|f
  covers106|f
  covers106|f
--- 46,52 ----
  containsproperly108|f
  containsproperly108|f
  containsproperly108|f
! ERROR:  lwgeom_size called with unknown-typed serialized geometry
  covers106|f
  covers106|f
  covers106|f
***************

Etc. etc.

There are actually more, including this:

*** tickets_expected    Fri Aug 17 11:48:27 2012
--- /tmp/pgis_reg_18825/test_50_out     Fri Aug 17 12:00:10 2012
***************
*** 49,98 ****
  #259|
  #260|1667701
  #261|0
! #262|POINT(-119.5434 34.9438)|t|t|t
...
--- 49,52 ----
  #259|
  #260|1667701
  #261|0
! connection to server was lost

Sounds pretty drastic }}}

Change History (1)

comment:1 Changed 7 years ago by strk

Resolution: invalid
Status: newclosed

Could not reproduce this, possibly a broken "make clean".

Note: See TracTickets for help on using tickets.