Opened 7 years ago

Closed 7 years ago

#1886 closed defect (fixed)

Outstanding release items for 2.0.1

Reported by: robe Owned by: chodgson
Priority: medium Milestone: PostGIS 2.0.1
Component: management Version: 2.0.x
Keywords: Cc:

Description

We have a couple of holes left in our release

1) No news notice on the site 2) No PDF document generated accessible from the site -- this is nowhere to be found -- http://www.postgis.org/download/postgis-2.0.1.pdf

3) Minor grip and mostly my fault -- I think we are missing a couple of news items like the last minute changes for shp2pgsql-gui, tiger

4) The doco is missing a release date (I'll fix this one).

Change History (6)

comment:1 Changed 7 years ago by chodgson

1) I never saw the release announcement (it wasn't posted to -devel?) so I couldn't post it - as per my earlier e-mail tot he PSC perhaps someone else should post this as a check that it can be done successfully

2) The PDF build and the code that puts it on the web site all happens in hudson, when a new release comes out hudson needs to be manually triggered (it is setup to build the actual release package as well). Again it might make sense for someone else to try this but if we just want it fixed pronto then I can do it.

3) You can include the news items in the news posting on the websie

4) Make sure we fix it before we build the PDF for (2).

comment:2 Changed 7 years ago by robe

Thanks Chris. I'm trying now. Hope you stand by in case I screw up badly.

comment:3 Changed 7 years ago by robe

Chris,

Thanks for the coaching. I have the news up and the pdf is generated

so 1, 2 are done.

So just need to work out why the release date isn't changing from hudson. I think its as you said I changed the wrong job. Probably have to create a new one.

I'll let you know if I get stuck.

comment:4 Changed 7 years ago by chodgson

The problem is that the postgis 2.0 deploy task is echoing the version info into trunk-version.php and then trying to copy over branch2.0-version.php. I *think* the branch2.0-version is the right one... but it might be worth looking at the docs and download pages to make sure. Here is the place with the broken script:

http://office.refractions.net:1500/job/PostGIS_2.0_Deploy/configure

You can see that the last time it ran it failed because of not finding the file to copy.

comment:5 Changed 7 years ago by chodgson

This was likely an error I made when transcribing/creating the 2.0 jobs as I was figuring things out as I went and was essentially merging the trunk build script with the branch build/deploy logic from 1.5.

comment:6 Changed 7 years ago by robe

Resolution: fixed
Status: newclosed

I think we are in good shape now. I figured out the last few bits. The postgis 2.0 deploy has the scp line to copy the tar ball to the site presumably to prevent 2.0.0 from being overritten. Now that I changed it from tagged to branch, that's a non-issue so put the line back.

I also had to change the cms_config to properly display the postgis 2.0 branhc revisions.

Only minor thing to fix which I'll do later is that the release html documentation is pointing at the branch build http://www.postgis.org/documentation/

I think this just requires changing the symlink. I accidentally messed it up when untagging and not changing another line. I'll fix that one later.

Note: See TracTickets for help on using tickets.