Opened 7 years ago

Closed 7 years ago

#1834 closed defect (fixed)

revise postgis extension to only backup user specified spatial_ref_sys

Reported by: robe Owned by: robe
Priority: medium Milestone: PostGIS 2.0.1
Component: build/upgrade/install Version: 2.0.x
Keywords: history Cc:

Description

right now if you install postgis as an extension and then do a full backup of your database, it backs up all spatial_ref_sys. It should only backup user created ones so you don't get a primary key conflict when you reload your data.

As a hacky solution until we figure out how to do #1831, I'm just going to change the configuration to expliclitly list out the ranges we have. It's not ideal but the easiest backward compatibility wise to do at the moment.

So essentially the extension part that reads:

SELECT pg_catalog.pg_extension_config_dump('spatial_ref_sys', '');

Will be changed to

SELECT pg_catalog.pg_extension_config_dump('spatial_ref_sys', 'srid NOT BETWEEN a1 and b1 AND srid NOT BETWEEN a2 and b2 ...');

We still have the issue of #1815, but I'm going to change that to a documentation fix that it's just by design that you can't backup spatial_ref_sys without backing up the whole database. Not great but it's not in our court to play.

Change History (1)

comment:1 Changed 7 years ago by robe

Keywords: history added
Resolution: fixed
Status: newclosed

done on 2.1.0 r9867, 2.0 r9869

Note: See TracTickets for help on using tickets.