Opened 8 years ago

Closed 4 years ago

#1159 closed task (fixed)

Draft an API header file for liblwgeom to install systemwide

Reported by: strk Owned by: postgis-devel@…
Priority: medium Milestone: PostGIS 2.1.0
Component: liblwgeom Version: trunk
Keywords: Cc:

Description (last modified by robe)

Installing the current liblwgeom.h, despite all cleanup efforts, still seems too much to maintain to me.

This ticket is to write a header file exclusively using opaque types.

Change History (4)

comment:1 Changed 8 years ago by robe

Description: modified (diff)

comment:2 Changed 8 years ago by strk

Component: postgisliblwgeom
Owner: changed from pramsey to postgis-devel@…

comment:3 Changed 7 years ago by pramsey

Milestone: PostGIS 2.0.0PostGIS Future

This is a Future item.

comment:4 Changed 4 years ago by strk

Milestone: PostGIS FuturePostGIS 2.1.0
Resolution: fixed
Status: newclosed

I guess this can be considered done, as we're installing liblwgeom.h already (and it's been cleaned up a lot, even if didn't get to reach opaque types)

Note: See TracTickets for help on using tickets.