Opened 7 years ago

Closed 7 years ago

#981 closed defect (fixed)

chroot build method: deegree fails to start

Reported by: darkblueb Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive6.0RC1
Component: OSGeoLive Keywords: beta8, chroot build method
Cc:

Description

after installing using beta8-alt deegree does not start.. manually executing the start script line by line shows

dbb@osgeolive:~$ export DEEGREE_WORKSPACE_ROOT="/usr/local/share/deegree"
dbb@osgeolive:~$ DEE_DIR="/usr/local/lib/deegree-webservices-3.2-pre9"
dbb@osgeolive:~$ cd $DEE_DIR
dbb@osgeolive:/usr/local/lib/deegree-webservices-3.2-pre9$ ./bin/catalina.sh start
Using CATALINA_BASE:   /usr/local/lib/deegree-webservices-3.2-pre9
Using CATALINA_HOME:   /usr/local/lib/deegree-webservices-3.2-pre9
Using CATALINA_TMPDIR: /usr/local/lib/deegree-webservices-3.2-pre9/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /usr/local/lib/deegree-webservices-3.2-pre9/bin/bootstrap.jar
touch: cannot touch `/usr/local/lib/deegree-webservices-3.2-pre9/logs/catalina.out': No such file or directory
dbb@osgeolive:/usr/local/lib/deegree-webservices-3.2-pre9$ ./bin/catalina.sh: 338: ./bin/catalina.sh: cannot create /usr/local/lib/deegree-webservices-3.2-pre9/logs/catalina.out: Directory nonexistent
dbb@osgeolive:/usr/local/lib/deegree-webservices-3.2-pre9$ 

Change history (4)

comment:1 Changed 7 years ago by kalxas

Summary: deegree failschroot build method: deegree fails to start

this looks like a permissions issue to me

comment:2 Changed 7 years ago by kalxas

I can start deegree by executing /usr/local/lib/deegree-webservices-3.2-pre9/start-deegree.sh so this probably has to do with start_deegree.sh

comment:3 Changed 7 years ago by hamish

Hi,

deegree starts ok for me in 6.0beta9 iso from the Geospatial menu, but froze my VM during the "Start" of the INSPIRE workspace noted in the quickstart. maybe just a kvm/qemu trouble..

maybe ok?

Hamish

comment:4 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

Works for me in beta9 live session under VBox. I was able to reproduce this freezing and the reason was that networking needed to restart in the VM. I am closing this as fixed in beta9.

Note: See TracTickets for help on using tickets.