Opened 7 years ago

Closed 6 years ago

#974 closed defect (wontfix)

remastersys iso installation fails

Reported by: darkblueb Owned by: kalxas
Priority: normal Milestone: OSGeoLive6.5
Component: OSGeoLive Keywords: 6.5
Cc: live-demo@…

Description

install completes but results in flawed system (see screenshots, taken soon after install and reboot)

Attachments (5)

b6a_iso_install_reboot.png (92.0 KB) - added by darkblueb 7 years ago.
b6a_f2.png (395.4 KB) - added by darkblueb 7 years ago.
iso-installation-error1.jpeg (37.7 KB) - added by kalxas 7 years ago.
iso-installation-error2.jpeg (47.2 KB) - added by kalxas 7 years ago.
iso-installation-error3.jpeg (45.2 KB) - added by kalxas 7 years ago.

Download all attachments as: .zip

Change history (18)

Changed 7 years ago by darkblueb

Attachment: b6a_iso_install_reboot.png added

Changed 7 years ago by darkblueb

Attachment: b6a_f2.png added

comment:1 Changed 7 years ago by kalxas

Just tested with beta7-backup iso and there is a mounting issue after rebooting.

Changed 7 years ago by kalxas

Changed 7 years ago by kalxas

Changed 7 years ago by kalxas

comment:2 Changed 7 years ago by kalxas

Keywords: 6.0 added; beta 6 alternate removed

I tested with all iso creation methods, dist, backup, dist without autologin. All produce the above errors

comment:3 Changed 7 years ago by kalxas

ok the errors in remastersys and chroot method are different after testing both. Mounting /run and / problem is not present in chroot method.

So after all this must be a remastersys error.

comment:4 Changed 7 years ago by kalxas

comment:5 Changed 7 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Status: newassigned

The problem with the alternate iso seems to be fixed now: http://aiolos.survey.ntua.gr/gisvm/dev/osgeo-live-mini-build8638.iso http://aiolos.survey.ntua.gr/gisvm/dev/osgeo-live-build8638.log

Just be careful NOT to create a "user" account during installation because that breaks lightdm (user is created during setup to help our current installation scripts).

Angelos

comment:6 Changed 7 years ago by kalxas

confirmed to be fixed in beta8-alternate. We can now actually ship a working iso.

comment:7 Changed 7 years ago by kalxas

Summary: iso installation failremastersys iso installation fails

This only applies to remastersys method now

comment:8 Changed 7 years ago by kalxas

Milestone: OSGeoLive6.0RC1
Priority: blockermajor

Since we are now planning releasing through chroot method this is not a blocker anymore.

comment:9 Changed 7 years ago by hamish

Cc: live-demo@… added

comment:10 Changed 7 years ago by hamish

Hi,

remastersys is just a couple of bash scripts.

to view/compare them, download (install) the .deb in the VM, then:

 mkdir remastersys
 cd remastersys
 ar x /var/cache/apt/archives/remastersys_3.0.3-1_all.deb
 tar xzf data.tar.gz
 tar xzf control.tar.gz

copy of that here: http://bambi.otago.ac.nz/hamish/livedvd/remastersys_deb_3.0.3-1_all.tgz

contains:

remastersys/
remastersys/data.tar.gz
remastersys/control
remastersys/etc/
remastersys/etc/remastersys.conf
remastersys/etc/remastersys/
remastersys/etc/remastersys/customisolinux/
remastersys/etc/remastersys/remastersys.version
remastersys/etc/remastersys/isolinux/
remastersys/etc/remastersys/isolinux/splash.png
remastersys/etc/remastersys/isolinux/isolinux.cfg.vesamenu
remastersys/etc/remastersys/preseed/
remastersys/etc/remastersys/preseed/custom.seed
remastersys/etc/remastersys/plymouth/
remastersys/etc/remastersys/plymouth/remastersys-theme/
remastersys/etc/remastersys/plymouth/remastersys-theme/remastersys-theme.script
remastersys/etc/remastersys/plymouth/remastersys-theme/progress_box.png
remastersys/etc/remastersys/plymouth/remastersys-theme/remastersys-theme.plymouth
remastersys/etc/remastersys/plymouth/remastersys-theme/progress_bar.png
remastersys/etc/remastersys/plymouth/remastersys-theme/remastersys.png
remastersys/control.tar.gz
remastersys/_gpgbuilder0
remastersys/_gpgbuilder
remastersys/debian-binary
remastersys/usr/
remastersys/usr/bin/
remastersys/usr/bin/remastersys-skelcopy
remastersys/usr/bin/remastersys
remastersys/usr/share/
remastersys/usr/share/applications/
remastersys/usr/share/doc/
remastersys/usr/share/doc/remastersys/
remastersys/usr/share/doc/remastersys/copyright
remastersys/usr/share/doc/remastersys/changelog.Debian.gz
remastersys/usr/share/doc/remastersys/README
remastersys/usr/share/man/
remastersys/usr/share/man/man1/
remastersys/usr/share/man/man1/remastersys.1.gz

Hamish

comment:11 Changed 7 years ago by camerons

Keywords: 6.5 added; 6.0 removed
Milestone: OSGeoLive6.5

After being unable to get the remastersys build script working in time for our 6.0 release, we have switched to using the chroot method. As such, I'm changing the milestone for this issue to 6.5.

comment:12 Changed 7 years ago by kalxas

Priority: majornormal

comment:13 Changed 6 years ago by kalxas

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.