Opened 10 years ago

Closed 7 years ago

#475 closed task (fixed)

Test Install of ISO

Reported by: wildintellect Owned by: kalxas
Priority: major Milestone:
Component: OSGeoLive Keywords: ISO install live 5.0
Cc: live-demo@…

Description

Can someone test if clicking the install button works work on a real machine or virtual machine? It would be nice to know if we should warn people that the install doesn't work right or not.

Change history (16)

comment:1 Changed 9 years ago by wildintellect

Keywords: 4.0 added
Type: taskdefect

Install from desktop icon failed on a virtual machine as reported by darkblue_b.

Most likely root cause is the process of iso creation provided by remastersys, should try to replace remastersys for version 4.0.

comment:2 Changed 9 years ago by hamish

more details with exact error messages etc would be helpful.

thanks, Hamish

comment:3 Changed 8 years ago by kalxas

Keywords: 4.5 added
Owner: changed from live-demo@… to kalxas
Status: newassigned

comment:4 Changed 8 years ago by hamish

Cc: live-demo@… added

comment:5 Changed 8 years ago by kalxas

Just tested the iso installation for 4.5 RC1 and worked great. I am keeping the issue open until we get confirmation from other users. Angelos

comment:6 Changed 8 years ago by darkblueb

using osgeo-live-4.5rc1a.iso install to disk in VirtualBox? 4 on Ubuntu Maverick the VM starts, gets a bottom toolbar and desktop icons but no top menu bar and no background image

comment:7 Changed 8 years ago by camerons

Priority: normalmajor

From chat discussions, it seems that the install worked for kalxas in 4.5rc1 from the boot menu, but didn't work for dbb when clicking the desktop icon install.

comment:8 Changed 8 years ago by darkblueb

no, that's not right. I have only used the boot menu install method - I have not used any desktop icon method

comment:9 Changed 8 years ago by kalxas

ok, I managed to reproduce the situation darkblueb reported. It seems that my installation was made using username: user and password: user and everything worked great. I installed again RC1a and used other login details. So I was logged in a XFCE Desktop very similar to KDE 3.x with no top bar. But all applications are in my desktop and work fine.

comment:10 Changed 8 years ago by wildintellect

I probably should have explained the difference between 4.5rc1 and 4.5rc1a sooner. 4.5rc1 was built using the "Backup" option of Remastersys 4.5rc1 was built using the "Dist" option of Remastersys (Also happens to have Mac/Win? installers)

With the Dist version the user is not saved as part of the image and fresh user is created at boot with some default stuff, most of which is stored in /etc/skel/ <- including xfce panel configurations. I'm putting whatever is in /home/user into /etc/skel before burning but that may not include customizations to xfce in /usr...

Anyways, the whole reason I tried this method was to see if it fixed the Autologin and default session issue. Can anyone say if 4.5rc1a does autologin and if it opens a Xubuntu session?

comment:11 in reply to:  10 Changed 8 years ago by hamish

Replying to wildintellect:

most of which is stored in /etc/skel/ <- including xfce panel configurations. I'm putting whatever is in /home/user into /etc/skel before burning but that may not include customizations to xfce in /usr...

cp -RnpP ${USER_HOME}/* /etc/skel/

pls confirm if the dot files get copied too. if not, one possible solution:

cp -RnpP ${USER_HOME}/* /etc/skel/
cp -RnpP ${USER_HOME}/.[a-zA-Z]* /etc/skel/

Hamish

comment:12 Changed 8 years ago by darkblueb

booted on the .iso rc1a I see many dot files, including .config [autostart, Thunar,user-dir.dirs, user-dir.locales, xfce4]. The installed to HD machine, also many dot files in home

comment:13 Changed 8 years ago by kalxas

Keywords: 5.0 added; 4.0 4.5 removed

comment:14 Changed 8 years ago by darkblueb

I booted on the RC1 .iso and installed (the Blue Face) and now use the installed system.. no problems that I could detect

comment:15 Changed 8 years ago by hamish

Type: defecttask

comment:16 Changed 7 years ago by camerons

Resolution: fixed
Status: assignedclosed

Seems to be fixed for release osgeolive 5.0+.

Note: See TracTickets for help on using tickets.