Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#447 closed defect (worksforme)

PgRouting Install Fails

Reported by: darkblueb Owned by: wildintellect
Priority: critical Milestone:
Component: OSGeoLive Keywords: pgrouting postgis postgres
Cc: live-demo@…

Description

svn rev 2185


... INSERT 0 1 ERROR: function dijkstra_sp_delta(unknown, integer, integer, numeric) does not exist LINE 1: SELECT gid, AsText?(the_geom) AS the_geom FROM dijkstra_sp_de...

HINT: No function matches the given name and argument types. You might need to add explicit type casts. ERROR: function astar_sp_delta(unknown, integer, integer, numeric) does not exist LINE 1: SELECT gid, AsText?(the_geom) AS the_geom FROM astar_sp_delta...

HINT: No function matches the given name and argument types. You might need to add explicit type casts. ERROR: function shootingstar_sp(unknown, integer, integer, numeric, unknown, boolean, boolean) does not exist LINE 1: SELECT gid, AsText?(the_geom) AS the_geom FROM shootingstar_s...

HINT: No function matches the given name and argument types. You might need to add explicit type casts.

Change history (4)

comment:1 Changed 10 years ago by wildintellect

The issue appears to be that the make install from pgrouting is not copying the .sql files from the source code in /tmp/pgrouting to it's appropriate place on the system /usr/share/postlbs/

So the loading of the functions doesn't happen and hence the tests as shown above fail.

comment:2 Changed 10 years ago by wildintellect

Owner: changed from live-demo@… to wildintellect
Status: newassigned

./install_pgrouting.sh: 107: cmake: not found

This appears to be the issue that's causing all the other problems. Testing what packages need to be installed in order for the build to work.

The following from the beta2 log may also be relevant The following packages have unmet dependencies:

libboost-graph-dev: Depends: libboost-dev (= 1.34.1-15ubuntu3) libcgal-dev: Depends: libboost-graph1.35-dev but it is not going to be installed

E: Broken packages

comment:3 Changed 10 years ago by wildintellect

Resolution: worksforme
Status: assignedclosed

fixed in changeset:2189 Caused by libboost package install failure.

Note: that script tests require user interaction to exit. Not sure if this is an issue or not.

comment:4 Changed 6 years ago by hamish

Cc: live-demo@… added

please move the ML email addr from the owner field if you take ownership of a ticket so it doesn't get lost

Note: See TracTickets for help on using tickets.