Opened 4 years ago

Closed 4 years ago

#1440 closed defect (fixed)

QGIS Server appears to be broken

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive8.5
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

In nightly build 12066

Change history (8)

comment:1 Changed 4 years ago by kalxas

bingo:

===============================================================
Starting "install_qgis_mapserver.sh" ...
===============================================================
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qgis-mapserver : Depends: qgis-providers (= 2.0.1-2build2) but 2.6.0-0trusty1 is to be installed
E: Unable to correct problems, you have held broken packages.

comment:2 Changed 4 years ago by kalxas

Same happens with the QGIS 2.6.1 deb package (post alpha2)

comment:3 Changed 4 years ago by Bas Couwenberg

The qgis-mapserver package was renamed in QGIS 2.6.0 to qgis-server.

Changing the install scripts to install qgis-server instead should resolve the problem:

Index: install_qgis_mapserver.sh
===================================================================
--- install_qgis_mapserver.sh   (revision 12080)
+++ install_qgis_mapserver.sh   (working copy)
@@ -37,8 +37,8 @@
 QS_APACHE_CONF=$APP_CONF_DIR$QS_APACHE_CONF_FILE
 APACHE_CONF_DIR="/etc/apache2/conf-available/"
 
-## get qgis_mapserver
-apt-get install --assume-yes qgis-mapserver libapache2-mod-fcgid
+## get qgis server
+apt-get install --assume-yes qgis-server libapache2-mod-fcgid
 
 # Make sure Apache has cgi-bin setup, and that fcgid is enabled
 a2enmod cgi

You'll also want to remove all the obsolete qgis packages for previous versions from the APT repository.

comment:4 Changed 4 years ago by kalxas

Resolution: fixed
Status: newclosed

(In [12081]) trying to fix #1440

comment:5 Changed 4 years ago by kalxas

Resolution: fixed
Status: closedreopened

trac automatically closed this ticket...

comment:6 Changed 4 years ago by kalxas

Thanks sebastic!

comment:7 Changed 4 years ago by kalxas

Priority: criticalmajor

Tested with: apt-get install qgis-server in build [12080] and it works fine. Waiting for next builds to close this ticket

comment:8 Changed 4 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

confirmed fixed in build [12081]

Note: See TracTickets for help on using tickets.