Opened 5 years ago

Closed 4 years ago

#1409 closed task (wontfix)

Examine Potential Conflicts in PGDG and Current Repos for PostgreSQL

Reported by: darkblueb Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive8.5
Component: OSGeoLive Keywords: postgis
Cc:

Description

PostgreSQL and Postgres Global Development Group repo packages may conflict; examine and verify

Change history (3)

comment:1 Changed 5 years ago by hamish

Milestone: UnplannedOSGeoLive8.5

Hi Brian,

technical: could you elaborate please? is this a request for an audit? what should that audit look at/for? Stepping back, what's the need + justification for including 3rd party packages? (ie are they critical; can we just make the problem go away by not including them?) What's the benefit?

As long as everything is in .debs, conflicting files in the filesystem will be flagged at install time with dpkg refusing to go on. If there is a structural conflict, the 3rd party .debs should have a Conflicts: line in its debian/control file which tells dpkg not to let the two packages co-exist. If they don't have that Conflicts line it's a bug we should file a ticket with them.

editorial: As you know, IMHO 3rd party PPAs are to be avoided as much as possible. :-) Especially if they touch core infrastructure packages it introduces many headaches for the many packages from many sources that depend on the original. (e.g. the fun caused by replacing official gdal packages)

Despite appearances I'm not totally against 3rd party installs, just that the benefits must be shown to firmly outweigh the costs. (if I have any bias it's because generally I only see the cost end of this transaction ending up in my lap when stuff breaks)

thanks, Hamish

comment:2 Changed 4 years ago by kalxas

AFAIK, PGDG is not using UbuntuGIS packages (GDAL etc) to build its PostGIS version. This means that we would need to do the opposite, re-base UbuntuGIS to PGDG, which I don't see happening.

This could have happened if both UbuntuGIS and PGDG were based on upstream Ubuntu packages...

I propose to close this ticket.

comment:3 Changed 4 years ago by darkblueb

Resolution: wontfix
Status: newclosed

originally Regine Obe asked me to look into this, so I filed this ticket. Now reading this .. it seems the primary intent of PGDG repo is to provide multiple versions of Postgres for a given Ubuntu release, instead of only one. The releases are intended to be identical to the mainstream Ubuntu release PostgreSQL package.

Note: See TracTickets for help on using tickets.