Opened 5 years ago

Closed 5 years ago

#1359 closed defect (fixed)

OSSIM installer fails on Trusty

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords: ossim
Cc: epifanio

Description

Setting up libossim1 (1.8.16-2~trusty1) ... Setting up ossim-core (1.8.16-2~trusty1) ... Processing triggers for libc-bin (2.19-0ubuntu6) ... Reading package lists... Building dependency tree... Reading state information... Package libqt3-mt is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libqt3-mt' has no installation candidate Reading package lists... Building dependency tree... Reading state information... E: Unable to locate package libpthread-stubs0 ERROR: Package install failed! Aborting.

Change history (8)

comment:1 Changed 5 years ago by hamish

I have commented out the offending packages, but that just means that the remaining prerequisites install ok, not that the application actually works.

regards, Hamish

comment:2 Changed 5 years ago by johanvdw

Is there a reason why we are not using the debian package (also available from ubuntugis). I can copy it over to our repo.

comment:3 Changed 5 years ago by kalxas

Priority: criticalmajor

This is now working. I would also like to have debian packages for this project, for every release we have the same issues.

comment:4 Changed 5 years ago by kalxas

OSSIMPlanet fails to start: unable to link to libosgViewer.so.80

comment:5 Changed 5 years ago by hamish

wants libosgViewer.so.80 but

/usr/lib/libosgViewer.so.3.2.0 /usr/lib/libosgViewer.so.99

are present on the disc.

rebuild of the executable required.

Hamish

comment:6 Changed 5 years ago by hamish

Cc: epifanio added; live-demo@… removed
Keywords: ossim added

comment:7 Changed 5 years ago by hamish

libosg 3.0.1 libs copied in from osgeolive 7.5 in r11623, with symlinks from them to libosg.80.

Hamish

comment:8 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed working in [11633]

Note: See TracTickets for help on using tickets.