Opened 5 years ago

Closed 5 years ago

#1280 closed defect (fixed)

Custom ossim build conflicts with otb and monteverdi

Reported by: kalxas Owned by: live-demo@…
Priority: critical Milestone: OSGeoLive7.9
Component: OSGeoLive Keywords: ossim, otb
Cc: live-demo@…

Description

Segmentation error (code dump)

Change history (5)

comment:1 Changed 5 years ago by kalxas

Priority: blockercritical

I have installed monteverdi and otb on a new Xubuntu VM from the OSGeoLive PPA and it works as expected. It has to be a conflict with other package.

comment:2 Changed 5 years ago by kalxas

Confirmed that this is a conflict with the OSSIM package. I deactivated OSSIM on the build 11059 and Monteverdi works fine.

OTB and Monteverdi builds are based on the PPA ossim package. Can someone please rebuild OSSIM based on the OSGeoLive PPA?

Cheers, Angelos

comment:3 Changed 5 years ago by kalxas

Summary: monteverdi fails to load after moving to new PPACustom ossim build conflicts with otb and monteverdi

comment:4 Changed 5 years ago by hamish

Keywords: ossim otb added

Hi,

yesterday Massimo re-built the ossim Qt apps on a local live-VM, then we extracted the executables, shared files, plugins, and libs into a tarball which is now at the download.osgeo.org site.

it's now in the install_ossim.sh script for testing; script set to bail out early, we can re-enable the rest once we know the main install works. There might be some more libs to install.

ossim-core command line apps & libs is up to date in UbuntuGIS ppa (ver 1.8.16), hopefully we can ossim-qt packaged and in there too some point soon, and then onto Debian.

see also

https://bugs.debian.org/cgi-bin/pkgreport.cgi?repeatmerged=no&src=ossim

Hamish

comment:5 Changed 5 years ago by kalxas

Resolution: fixed
Status: newclosed

Confirmed, new build is working with OTB. Thanks Massimo and Hamish.

Note: See TracTickets for help on using tickets.