Opened 5 years ago

Closed 5 years ago

#1272 closed enhancement (invalid)

PostGIS package built with libgdal1h

Reported by: darkblueb Owned by: live-demo@…
Priority: major Milestone:
Component: OSGeoLive Keywords: libgdal1h, postgis
Cc:

Description

johanvdw has built a PostGIS package using libgdal1h and PostgreSQL 9.3, in his own PPA. This ticket is to track intermediate steps while we find the right organization of PPAs.

Change history (3)

comment:1 Changed 5 years ago by darkblueb

A fundemental challenge is -- apt.postgresql.org has a package called postgis, which is built on a different libgdal. It is possible to prioritize a PPA with something like this, in /etc/apt/preferences.d/

Package: *
Pin: release o=LP-PPA-johanvdw-osgeolive
Pin-Priority: -10
 
Package: postgis
Pin: release o=LP-PPA-johanvdw-osgeolive
Pin-Priority: 600

diagnostics are available with:

apt-cache policy
apt-cache show postgis

comment:2 Changed 5 years ago by darkblueb

from IRC: you shouldn't need to disable the repos, just prioritise the packages from your preferred repo

when you have conflicting packages its good to set the unwanted pages to a lower priority (or negative priority preferably) and only prioritise the necessary packages above all else. issues of couse do arise when there's dependencies involved and you may need to set priorities for a number of packages

comment:3 Changed 5 years ago by kalxas

Resolution: invalid
Status: newclosed

We have moved to one PPA for OSGeoLive, so this gets closed.

Note: See TracTickets for help on using tickets.