Opened 6 years ago

Closed 2 years ago

#1212 closed enhancement (fixed)

52nSOS stop memory and processes

Reported by: darkblueb Owned by: live-demo@…
Priority: minor Milestone: OSGeoLive8.0
Component: OSGeoLive Keywords: 52nSOS, tomcat
Cc:

Description

A very clean way to shutdown 52nSOS has not yet been written. The existing stop leaves a process tree using 100M of RAM.

http://ct.light42.com/www_shared/52nSOS_start_tree_rc1.png

Change history (6)

comment:1 Changed 6 years ago by kalxas

I tested stopping 52nSOS and monitor with htop and I could not reproduce your result. Did you try to close the Firefox instance that pops with 52nSOS?

In my test, tomcat6 is shut down completely, as expected.

comment:2 Changed 6 years ago by darkblueb

there might be some set of actions that leads to this result, but.. it is not at all important enough to block RC1 IMO (in my opinion)... just some testing..

comment:3 Changed 6 years ago by hamish

Priority: normalminor

for me those firefox processes get held open until you close down the 52nSOS tab in Firefox. (ps fax | less lumps them all into 1 row fwiw) The 52nSOS startup script is held open until firefox is closed.

perhaps the 52sSOS-start.sh script would be better to "exec" the firefox command?

Hamish

comment:4 Changed 5 years ago by kalxas

Milestone: OSGeoLive7.0OSGeoLive8.0

comment:5 Changed 2 years ago by ehjuerrens

Is this still an issue or can we close it?

comment:6 Changed 2 years ago by kalxas

Resolution: fixed
Status: newclosed

Fixed in current version

Note: See TracTickets for help on using tickets.