Opened 6 years ago

Closed 3 years ago

#1182 closed enhancement (wontfix)

create UbuntuGIS package for spatialite-gui and spatialite-gis

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive10.0
Component: OSGeoLive Keywords: spatialite
Cc:

Description

Those are still being built during chroot, having a deb for both would speed-up Live build

Change history (11)

comment:1 Changed 6 years ago by wildintellect

I believe these are in Ubuntugis (at least thats where I install from, not sure about gui), but Jerome needs to check which versions. Especially with that confusion over QGIS 1.8 not playing well with Spatialite 4 yet. I forget if that means we have to ship 3.x so that qgis can open the files and switch to to 4.x when QGIS goes to 2.0 next version.

comment:3 Changed 6 years ago by kalxas

Milestone: OSGeoLive7.0OSGeoLive7.5

comment:4 Changed 5 years ago by kalxas

Milestone: OSGeoLive7.9OSGeoLive8.0

comment:5 Changed 5 years ago by hamish

Keywords: spatialite added

spatialite-gui is now a deb package in the PPA,

https://launchpad.net/~osgeolive/+archive/ubuntu/release-8.0/+packages

not sure what happened to spatialite-gis, it's not on the disc. (??) but is still discussed in the quickstart doc.

Hamish

comment:6 Changed 5 years ago by kalxas

Milestone: OSGeoLive8.0OSGeoLive8.5

Hi Hamish,

The spatialite-gis used to be installed from source, but since the spatialite deb package was created, there was no volunteer time to add this part into the Debian package.

Lets leave this ticket open to remember this.

comment:7 Changed 4 years ago by kalxas

Milestone: OSGeoLive8.5OSGeoLive9.0

comment:8 Changed 4 years ago by Bas Couwenberg

spatialite-gis has been deprecated by its upstream developer, see: http://www.gaia-gis.it/gaia-sins/

Because of its deprecation I don't think it's suitable for OSGeo-Live.

spatialite-gui could be updated to the 2.0.0 pre-release available in Debian, you can then drop libgaiagraphics because it's no longer used as it's replaced by librasterlite2 (you still need the also deprecated librasterlite for mapnik).

comment:9 Changed 4 years ago by kalxas

Milestone: OSGeoLive9.0OSGeoLive9.5

Ticket retargeted after milestone closed

comment:10 Changed 3 years ago by kalxas

Milestone: OSGeoLive9.5OSGeoLive10.0

Ticket retargeted after milestone closed

comment:11 Changed 3 years ago by kalxas

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.