Opened 6 years ago

Closed 6 years ago

#1176 closed defect (fixed)

grass upgrade to 6.4.3 not installable on disk

Reported by: kalxas Owned by: live-demo@…
Priority: blocker Milestone: OSGeoLive7.0
Component: OSGeoLive Keywords: grass, ubuntugis
Cc:

Description

grass logs from build 10513:

Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grass : Depends: grass-core but it is not going to be installed
         Depends: grass-gui but it is not going to be installed
 grass-dev : Depends: grass-core (= 6.4.3~1precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ERROR: Package install failed! Aborting 

QGIS fails to install too.

Change history (5)

comment:1 Changed 6 years ago by hamish

Keywords: grass ubuntugis added

I'd give it 24 hours for the ppa to settle down before worrying too much about it.

Hamish

comment:2 Changed 6 years ago by kalxas

yes it starts to settle. I will confirm on the next nightly build

comment:3 Changed 6 years ago by kalxas

BTW this is a very good example of Launchpad's bad design. All dependencies should be built automatically when a new file is uploaded and all new files should be released at the same time. This would keep the ppa stable until files get switched all together.

Perhaps I am used to the way OBS works ;)

comment:4 Changed 6 years ago by kalxas

grass is now installed in build 10524

qgis still missing.

comment:5 Changed 6 years ago by kalxas

Resolution: fixed
Status: newclosed

confirmed fixed in build 10528

Note: See TracTickets for help on using tickets.