Opened 6 years ago

Closed 6 years ago

#1136 closed defect (fixed)

Cartaro not working after GeoServer upgrade

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive7.0
Component: OSGeoLive Keywords: cartaro
Cc:

Description

GeoServer? is currently at version 2.3.2 (expected to go to 2.3.3 for our final release)

Change history (10)

comment:1 Changed 6 years ago by phaf

We updated the installer script to work with GeoServer? 2.3.2 (r10183)

Sadly, we are currently suffering under several further problems with GeoServer? 2.3.X. We are busy with testing and fixing.

comment:2 Changed 6 years ago by phaf

  • We released a new version of Cartaro to fix the issues with GeoServer? 2.3.X. The installer script was updated to use the newest version. We have to verify this fix in one of the next nightly builds.
  • We still have to enable JSONP for GeoServer? as discussed on the mailing list. Only after enabling it, Cartaro would work correctly.

comment:3 Changed 6 years ago by kalxas

Thanks

Lets enable JSONP

comment:4 Changed 6 years ago by phaf

JSONP is now enabled r10338. I am waiting for the next build to check it. As PostGIS was broken during the last builds, installation of Cartaro also failed. Have to check again, if PostGIS is fixed.

comment:5 Changed 6 years ago by kalxas

I have just tested build 10365 and I cannot see the capitals on the map. Can you please confirm?

comment:6 Changed 6 years ago by phaf

Yes, I can confirm this. This happens, because JSON_P is still not enabled (the change in commit r10338 was removed).

For me it is unclear which way of activating would be acceptable for all (but activating in general seems to be okay for everybody). We had several discussions on the mailinglist but without result.

I see two options:

a) Modifying install_geoserver.sh to add the it directly to the startup script

In order to run Cartaro with GeoServer? 2.3, it is necessary to set the java system variable ENABLE_JSONP=true to enable the JSONP (text/javascript) output format. This can be done in /usr/local/lib/geoserver-2.3.2/bin/startup.sh

Line 71

  • export JAVA_OPTS="-XX:MaxPermSize=128m"

+ export JAVA_OPTS="-XX:MaxPermSize=128m -DENABLE_JSONP=true"

b) Change startup script for Cartaro (start_cartaro.sh) and export JAVA_OPTS there before GeoServer? will be started.

I would prefer the second option. What do you think?

comment:7 Changed 6 years ago by kalxas

Hi,

Thanks for the feedback. I am ok with both solutions. The second seems to be more targeted, so I believe it is preferable.

comment:8 Changed 6 years ago by phaf

The second option is implemented in r10375. We are going to check it in the next build.

comment:9 Changed 6 years ago by hamish

Keywords: cartaro added

thanks, if the second option doesn't work we can fall back to the first one and hope for the best.

one thing you might try is to check for/add to existing JAVA_OPTS:

if [ -z "$JAVA_OPTS" ] ; then
   JAVA_OPTS="-DENABLE_JSONP=true -XX:MaxPermSize=128m"
else
   JAVA_OPTS="$JAVA_OPTS -DENABLE_JSONP=true -XX:MaxPermSize=128m"
fi

regards, Hamish

comment:10 Changed 6 years ago by kalxas

Resolution: fixed
Status: newclosed

fixed and confirmed in [10378]

Note: See TracTickets for help on using tickets.