Opened 6 years ago

Closed 6 years ago

#1129 closed defect (fixed)

GeoNetwork includes internal GeoServer

Reported by: kalxas Owned by: live-demo@…
Priority: major Milestone: OSGeoLive7.0
Component: OSGeoLive Keywords:
Cc:

Description

In order to optimize for disk space, we need all the applications to be installed once in the disk. GeoNetwork? should be packaged to work with stock GeoServer? for the next release.

Attachments (1)

geonetwork_osgeolive7.jpeg (76.9 KB) - added by kalxas 6 years ago.

Download all attachments as: .zip

Change history (8)

comment:1 Changed 6 years ago by kalxas

first pass in [10178]

comment:2 Changed 6 years ago by kalxas

From the latest build (10180) logs:

328704K ........ ...... 100% 21.4M=19s

2013-06-17 18:23:30 (17.3 MB/s) - `download' saved [337520946/337520946]

./install_geonetwork.sh: 93: ./install_geonetwork.sh: -O: not found /usr/local/share/gisvm/bin/../app-conf/geonetwork/install.xml' -> ./install.xml' /usr/local/share/gisvm/bin/../app-conf/geonetwork/jetty.xml' -> ./jetty.xml' /usr/local/share/gisvm/bin/../app-conf/geonetwork/config-gui.xml' -> ./config-gui.xml' /usr/local/share/gisvm/bin/../app-conf/geonetwork/start-geonetwork.sh' -> ./start-geonetwork.sh' /usr/local/share/gisvm/bin/../app-conf/geonetwork/stop-geonetwork.sh' -> ./stop-geonetwork.sh' /usr/local/share/gisvm/bin/../app-conf/geonetwork/data-db-default.sql' -> ./data-db-default.sql' /usr/local/share/gisvm/bin/../app-conf/geonetwork/iso-19139-basins-in-africa.mef' -> ./iso-19139-basins-in-africa.mef' /usr/local/share/gisvm/bin/../app-conf/geonetwork/iso-19139-physiographic.mef' -> ./iso-19139-physiographic.mef' Error: Unable to access jarfile geonetwork-install-2.10.0-0.jar cp: cannot create regular file `/usr/lib/geonetwork/jetty/etc/jetty.xml': No such file or directory cp: cannot create regular file `/usr/lib/geonetwork/web/geonetwork/WEB-INF/config-gui.xml': No such file or directory cp: cannot create regular file `/usr/lib/geonetwork/web/geonetwork/WEB-INF/classes/setup/sql/data/.': No such file or directory cp: cannot create regular file `/usr/lib/geonetwork/bin/start-geonetwork.sh': No such file or directory cp: cannot create regular file `/usr/lib/geonetwork/bin/stop-geonetwork.sh': No such file or directory chgrp: cannot access `/usr/lib/geonetwork/jetty': No such file or directory chgrp: cannot access `/usr/lib/geonetwork/jetty/logs': No such file or directory chgrp: cannot access `/usr/lib/geonetwork/web/geonetwork/WEB-INF/': No such file or directory chgrp: cannot access `/usr/lib/geonetwork/web/geonetwork/images/logos': No such file or directory chmod: cannot access `/usr/lib/geonetwork/jetty': No such file or directory chmod: cannot access `/usr/lib/geonetwork/jetty/logs': No such file or directory chmod: cannot access `/usr/lib/geonetwork/web/geonetwork/WEB-INF/': No such file or directory chmod: cannot access `/usr/lib/geonetwork/web/geonetwork/images/logos': No such file or directory The user user' is already a member of users'. /usr/local/share/gisvm/bin/../app-conf/geonetwork/start_geonetwork.desktop' -> ./start_geonetwork.desktop' /usr/local/share/gisvm/bin/../app-conf/geonetwork/stop_geonetwork.desktop' -> ./stop_geonetwork.desktop' /usr/local/share/gisvm/bin/../app-conf/geonetwork/geonetwork.desktop' -> ./geonetwork.desktop'

comment:3 Changed 6 years ago by fxp

Fixed wget download option in http://trac.osgeo.org/osgeo/changeset/10181

comment:4 Changed 6 years ago by kalxas

Thanks for the fix. This is the log of 10181 build:

2013-06-18 09:32:29 (16.7 MB/s) - `geonetwork-install-2.10.0-0.jar' saved [337520946/337520946]

/usr/local/share/gisvm/bin/../app-conf/geonetwork/install.xml' -> ./install.xml' /usr/local/share/gisvm/bin/../app-conf/geonetwork/jetty.xml' -> ./jetty.xml' /usr/local/share/gisvm/bin/../app-conf/geonetwork/config-gui.xml' -> ./config-gui.xml' /usr/local/share/gisvm/bin/../app-conf/geonetwork/start-geonetwork.sh' -> ./start-geonetwork.sh' /usr/local/share/gisvm/bin/../app-conf/geonetwork/stop-geonetwork.sh' -> ./stop-geonetwork.sh' /usr/local/share/gisvm/bin/../app-conf/geonetwork/data-db-default.sql' -> ./data-db-default.sql' /usr/local/share/gisvm/bin/../app-conf/geonetwork/iso-19139-basins-in-africa.mef' -> ./iso-19139-basins-in-africa.mef' /usr/local/share/gisvm/bin/../app-conf/geonetwork/iso-19139-physiographic.mef' -> ./iso-19139-physiographic.mef' [ Starting automated installation ] Read pack list from xml definition. Try to add to selection [Name: Core and Index: 0] Try to remove from selection [Name: GeoServer and Index: 1] Try to remove from selection [Name: European Union INSPIRE Directive configuration pack and Index: 2] Try to remove from selection [Name: GAST and Index: 3] Modify pack selection. Pack [Name: GeoServer and Index: 1] removed from selection. Pack [Name: European Union INSPIRE Directive configuration pack and Index: 2] removed from selection. Pack [Name: GAST and Index: 3] removed from selection. [ Starting to unpack ] [ Processing package: Core (1/1) ] [ Unpacking finished ] [ Creating shortcuts ....... done. ] [ Add shortcuts to uninstaller done. ] [ Writing the uninstaller data ... ] [ Automated installation done ] The user user' is already a member of users'. /usr/local/share/gisvm/bin/../app-conf/geonetwork/start_geonetwork.desktop' -> ./start_geonetwork.desktop' /usr/local/share/gisvm/bin/../app-conf/geonetwork/stop_geonetwork.desktop' -> ./stop_geonetwork.desktop' /usr/local/share/gisvm/bin/../app-conf/geonetwork/geonetwork.desktop' -> ./geonetwork.desktop'

The problem is that after GN startup, the home ican leads to the following 404 error (see screenshot)

Changed 6 years ago by kalxas

Attachment: geonetwork_osgeolive7.jpeg added

comment:5 Changed 6 years ago by fxp

Error on startup:

2013-07-01 06:10:13.357:WARN::FAILED o.e.j.w.WebAppContext{/geonetwork,file:/usr/lib/geonetwork/web/geonetwork/},/usr/lib/geonetwork/web/geonetwork: java.lang.ExceptionInInitializerError
2013-07-01 06:10:13.357:WARN::Unable to reach node goal: started
java.lang.ExceptionInInitializerError
	at org.fao.geonet.resources.Resources.<clinit>(Resources.java:43)
	at org.fao.geonet.Geonetwork.start(Geonetwork.java:275)
	at jeeves.server.JeevesEngine.initAppHandler(JeevesEngine.java:600)
	at jeeves.server.JeevesEngine.init(JeevesEngine.java:206)
	at jeeves.server.sources.http.JeevesServlet.init(JeevesServlet.java:91)
	at javax.servlet.GenericServlet.init(GenericServlet.java:241)
	at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:432)
	at org.eclipse.jetty.servlet.ServletHolder.doStart(ServletHolder.java:260)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.servlet.ServletHandler.initialize(ServletHandler.java:763)
	at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:245)
	at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1158)
	at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:587)
	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:436)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.deploy.bindings.StandardStarter.processBinding(StandardStarter.java:36)
	at org.eclipse.jetty.deploy.AppLifeCycle.runBindings(AppLifeCycle.java:180)
	at org.eclipse.jetty.deploy.DeploymentManager.requestAppGoal(DeploymentManager.java:479)
	at org.eclipse.jetty.deploy.DeploymentManager.addApp(DeploymentManager.java:136)
	at org.eclipse.jetty.deploy.providers.ScanningAppProvider.fileAdded(ScanningAppProvider.java:137)
	at org.eclipse.jetty.deploy.providers.ScanningAppProvider$1.fileAdded(ScanningAppProvider.java:50)
	at org.eclipse.jetty.util.Scanner.reportAddition(Scanner.java:494)
	at org.eclipse.jetty.util.Scanner.reportDifferences(Scanner.java:406)
	at org.eclipse.jetty.util.Scanner.scan(Scanner.java:355)
	at org.eclipse.jetty.util.Scanner.start(Scanner.java:290)
	at org.eclipse.jetty.deploy.providers.ScanningAppProvider.doStart(ScanningAppProvider.java:114)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.deploy.DeploymentManager.startAppProvider(DeploymentManager.java:540)
	at org.eclipse.jetty.deploy.DeploymentManager.doStart(DeploymentManager.java:219)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.util.component.AggregateLifeCycle.doStart(AggregateLifeCycle.java:42)
	at org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:52)
	at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:96)
	at org.eclipse.jetty.server.Server.doStart(Server.java:258)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.xml.XmlConfiguration$1.run(XmlConfiguration.java:1233)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1156)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.eclipse.jetty.start.Main.invokeMain(Main.java:477)
	at org.eclipse.jetty.start.Main.start(Main.java:623)
	at org.eclipse.jetty.start.Main.parseCommandLine(Main.java:273)
	at org.eclipse.jetty.start.Main.main(Main.java:81)
Caused by: 
java.lang.SecurityException: sealing violation: package com.sun.media.imageioimpl.stream is sealed
	at java.net.URLClassLoader.getAndVerifyPackage(URLClassLoader.java:388)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:417)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:411)
	at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:373)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:266)
	at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:363)
	at java.util.ServiceLoader$1.next(ServiceLoader.java:445)
	at javax.imageio.spi.IIORegistry.registerApplicationClasspathSpis(IIORegistry.java:210)
	at javax.imageio.spi.IIORegistry.<init>(IIORegistry.java:138)
	at javax.imageio.spi.IIORegistry.getDefaultInstance(IIORegistry.java:159)
	at javax.imageio.ImageIO.<clinit>(ImageIO.java:65)
	at org.fao.geonet.resources.Resources.<clinit>(Resources.java:43)
	at org.fao.geonet.Geonetwork.start(Geonetwork.java:275)
	at jeeves.server.JeevesEngine.initAppHandler(JeevesEngine.java:600)
	at jeeves.server.JeevesEngine.init(JeevesEngine.java:206)
	at jeeves.server.sources.http.JeevesServlet.init(JeevesServlet.java:91)
	at javax.servlet.GenericServlet.init(GenericServlet.java:241)
	at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:432)
	at org.eclipse.jetty.servlet.ServletHolder.doStart(ServletHolder.java:260)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.servlet.ServletHandler.initialize(ServletHandler.java:763)
	at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:245)
	at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1158)
	at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:587)
	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:436)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.deploy.bindings.StandardStarter.processBinding(StandardStarter.java:36)
	at org.eclipse.jetty.deploy.AppLifeCycle.runBindings(AppLifeCycle.java:180)
	at org.eclipse.jetty.deploy.DeploymentManager.requestAppGoal(DeploymentManager.java:479)
	at org.eclipse.jetty.deploy.DeploymentManager.addApp(DeploymentManager.java:136)
	at org.eclipse.jetty.deploy.providers.ScanningAppProvider.fileAdded(ScanningAppProvider.java:137)
	at org.eclipse.jetty.deploy.providers.ScanningAppProvider$1.fileAdded(ScanningAppProvider.java:50)
	at org.eclipse.jetty.util.Scanner.reportAddition(Scanner.java:494)
	at org.eclipse.jetty.util.Scanner.reportDifferences(Scanner.java:406)
	at org.eclipse.jetty.util.Scanner.scan(Scanner.java:355)
	at org.eclipse.jetty.util.Scanner.start(Scanner.java:290)
	at org.eclipse.jetty.deploy.providers.ScanningAppProvider.doStart(ScanningAppProvider.java:114)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.deploy.DeploymentManager.startAppProvider(DeploymentManager.java:540)
	at org.eclipse.jetty.deploy.DeploymentManager.doStart(DeploymentManager.java:219)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.util.component.AggregateLifeCycle.doStart(AggregateLifeCycle.java:42)
	at org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:52)
	at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:96)
	at org.eclipse.jetty.server.Server.doStart(Server.java:258)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
	at org.eclipse.jetty.xml.XmlConfiguration$1.run(XmlConfiguration.java:1233)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1156)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.eclipse.jetty.start.Main.invokeMain(Main.java:477)
	at org.eclipse.jetty.start.Main.start(Main.java:623)
	at org.eclipse.jetty.start.Main.parseCommandLine(Main.java:273)
	at org.eclipse.jetty.start.Main.main(Main.java:81)

comment:7 Changed 6 years ago by kalxas

Resolution: fixed
Status: newclosed

Confirmed fixed in build [10265]. Thanks

Note: See TracTickets for help on using tickets.