Opened 6 years ago

Closed 6 years ago

#1033 closed defect (fixed)

GeoServer fails to start

Reported by: kalxas Owned by: kalxas
Priority: normal Milestone: OSGeoLive6.5
Component: OSGeoLive Keywords: 6.5 alpha 4
Cc: live-demo@…

Description

After starting up GeoServer?, home page is not shown. The error is: HTTP ERROR: 503 SERVICE UNAVAILABLE

Change history (12)

comment:1 Changed 6 years ago by darkblueb

it is at least a permissions problem, beginning with this

java.io.FileNotFoundException: /usr/local/lib/geoserver-2.2/data_dir/logs/geoserver.log (Permission denied)

sudo execute the startupscript, and it succeeds normally

comment:2 Changed 6 years ago by darkblueb

fix checked in, rev 9448

comment:3 Changed 6 years ago by phaf

I am little bit unsure whether this issue is already fixed or not. After building a new live cd, group rights are now set correctly for data_dir and logs:

+chmod -R g+w "$GS_HOME/data_dir" +chmod -R g+w "$GS_HOME/logs"

But starting GeoServer? with user rights via /usr/local/bin/geoserver_start_admin.sh still fails, because the owner group with id 1000 does not exist. Does something get wrong with my building process or is it a real problem? Has someone else already checked it?

comment:4 Changed 6 years ago by kalxas

When you trigger the build do you do it from a "user" account on your host machine? This another user is used the build will have such issues... this is why I make the builds in a VM with a "user" account

comment:5 Changed 6 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Status: newassigned

we still experience permission issues for alpha5.

comment:6 Changed 6 years ago by kalxas

Priority: blockercritical

I have just fixed this issue by reverting to OSGeoLive 6.0 script and applying version updates. The problem is that live session user does not belong to users group. Also folders data_dir and logs have to be writable.

Waiting for confirmation on the next build to close this one.

comment:7 Changed 6 years ago by kalxas

Priority: criticalnormal

confirmed on build 9490 I will close this on alpha6

comment:8 Changed 6 years ago by kalxas

Resolution: fixed
Status: assignedclosed

There has been a small conflict with Cartaro installation script running Geoserver at build time. This is now fixed in [9505] and confirmed on a nightly build.

comment:9 Changed 6 years ago by hamish

Cc: live-demo@… added
Resolution: fixed
Status: closedreopened

please move the ML email addr from the owner field if you take ownership of a ticket so it doesn't get lost

---

Global write permissions are no good on the DVD. Do not use it:

chmod -R a+w

instead use the chmod g+w; chgrp $GROUP; adduser user $GROUP solution, where $GROUP is either 'users' for desktop apps or 'www-data' for apache things.

thanks, Hamish

comment:10 Changed 6 years ago by darkblueb

GeoServer? starts and serves layers in build 9640

comment:11 Changed 6 years ago by hamish

I was getting a 404 error today, but it seems to have gone away. maybe I didn't wait long enough for it to boot. More tests tomorrow after the latest round of Cartaro changes are confirmed.

comment:12 Changed 6 years ago by kalxas

Resolution: fixed
Status: reopenedclosed

confirmed to work on build [9647]

Note: See TracTickets for help on using tickets.