Opened 7 years ago

Closed 7 years ago

#1001 closed defect (fixed)

6.0 Failed to install to hard drive

Reported by: Aborrell Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive6.0Final
Component: OSGeoLive Keywords: ubiquity, 6.0-full
Cc:

Description

Tried to install the live dvd osgeo 6.0 (md5 chacked), both from dvd and from an usb image. After selecting the language, there is a crash reporting an error from /usr/lib/ubiquity/bin/ubiquity. and then closes the application. I've tried several machines, several languages with no success. The systems had other operating systems installed on it, but I tried with an empty hard disk with no luck. Yet it worked with version 5.5

Change history (16)

comment:1 Changed 7 years ago by warmerdam

Component: Systems AdminLiveDVD
Owner: changed from sac@… to live-demo@…

comment:2 in reply to:  description Changed 7 years ago by kalxas

Keywords: 6.0 added
Type: taskdefect

Replying to Aborrell:

Tried to install the live dvd osgeo 6.0 (md5 chacked), both from dvd and from an usb image. After selecting the language, there is a crash reporting an error from /usr/lib/ubiquity/bin/ubiquity. and then closes the application. I've tried several machines, several languages with no success. The systems had other operating systems installed on it, but I tried with an empty hard disk with no luck. Yet it worked with version 5.5

Hi Aborrell,

Did you use the mini or the full iso? Which language did you try to install? Can you send here the partition setup you tried to create?

Installing to an empty hard disk has been tested to work ok so far, can you provide machine specs on which this error occurred? Did you use the default partition setup for this test?

Regards, Angelos

comment:3 Changed 7 years ago by hamish

Priority: majorcritical
Summary: Failed to install6.0 Failed to install to hard drive

(see also ML post http://lists.osgeo.org/pipermail/live-demo/2012-August/006162.html)

Hi,

I can reproduce this with the 6.0 full iso, trying to install to a VM image drive with kvm/qemu. Also if I press the any key at bootup and select "Install Xubuntu" from the old boot menu, it just ignores that and boots up as the regular user.

The exact timing of when we did the test installs slips my mind, but perhaps our last minute neutering of ubiquity caused some collateral damage? And yet Alex was able to create a VM from an iso, right? Was the mini used for that? If so, maybe it was the remastering of the full iso which caused the trouble? The error message in the above ML post (& I get the same one) had something to do about reading the filesystem size.

As a start, to test the neutered-ubiquity at start we can manually undo the change to /etc/init/ubiquity.conf while booted in the iso. But before trying that I'll try installing from a final mini.iso.

Hamish

comment:4 Changed 7 years ago by micha

I was able to install a VM (VirtualBox?) from the mini-iso, straight from the boot screen with no problem.

comment:5 in reply to:  3 Changed 7 years ago by kalxas

Hi,

All the iso testing I did (including the final build) was based on the mini iso, which I can confirm that works ok during installation.

Alex, can you please create a "OSGeoLive6.0.1" Milestone in Trac to assign?

Thanks, Angelos

Replying to hamish:

Hi,

I can reproduce this with the 6.0 full iso, trying to install to a VM image drive with kvm/qemu. Also if I press the any key at bootup and select "Install Xubuntu" from the old boot menu, it just ignores that and boots up as the regular user.

The exact timing of when we did the test installs slips my mind, but perhaps our last minute neutering of ubiquity caused some collateral damage? And yet Alex was able to create a VM from an iso, right? Was the mini used for that? If so, maybe it was the remastering of the full iso which caused the trouble? The error message in the above ML post (& I get the same one) had something to do about reading the filesystem size.

As a start, to test the neutered-ubiquity at start we can manually undo the change to /etc/init/ubiquity.conf while booted in the iso. But before trying that I'll try installing from a final mini.iso.

Hamish

comment:6 Changed 7 years ago by hamish

Keywords: 6.0-full added; 6.0 removed

I too can install to a VM hard drive from the desktop icon on the mini. The bootup press-a-key install option just boots to the OS instead of starting the installer, but that's a minor issue I think we can ignore for now.

It seems to me that a 6.0.1 is not needed, as none of the base system needs to change, just the post-processing which creates the full version. So we just need to issue a osgeolive-full-6.0.0-2.iso. I'd wait to clutter the trac system with a new milestone until we have a bad bug which really is in the base install requiring a full rebuild.

thanks, Hamish

comment:7 Changed 7 years ago by hamish

hmmm,

/media/cdrom/casper/filesystem.size on the mini iso contains 8331337728.

/media/cdrom/casper/filesystem.size on the full iso contains nothing, it's an empty file.

see also source:livedvd/gisvm/trunk/bin/build_full_iso.sh#L85

Hamish

comment:8 Changed 7 years ago by kalxas

This is definitely the reason of failure. The good side is that we won't need rebuilding the mini...

comment:9 Changed 7 years ago by wildintellect

I fixed source:livedvd/gisvm/trunk/bin/build_full_iso.sh#L85 (commented out that extraneous part) but ran into other issues re-running the script (github https error about certificates, something to look into next build cycle).

Plan B. remastered by hand copying the filesystem.size from mini to full and making a new image. I've put the new image up for testing, once we confirm I'll replace the image on sourceforge. http://live.osgeo.org/dev/build/ osgeo-live-6.0-1.iso osgeo-live-6.0-1.iso.md5

comment:10 in reply to:  9 Changed 7 years ago by kalxas

Thanks Alex,

I will test tomorrow and let you know.

Cheers, Angelos

comment:11 Changed 7 years ago by darkblueb

I downloaded this .iso ( for me that was 50 minutes to download)

http://osprey.ucdavis.edu/downloads/osgeo/gisvm/latest/osgeo-live-6.0-1.iso

and burned a physical disk however, the disk, and the .iso file, are returning "bad checksum" when I try to boot. Please advise

comment:12 Changed 7 years ago by kalxas

Yes, Alex already posted on the list that there is a checksum problem and to ignore this iso.

comment:13 Changed 7 years ago by darkblueb

I downloaded .../gisvm/latest/osgeo-live-6.0-3.iso and used it to boot, unfortunately when I invoke the install language menu at boot time, then choose install system, the installer does not run, instead it simply boots to the Live desktop. I have verified this behavior here. (using the installer from the running system's desktop functions normally)

comment:14 Changed 7 years ago by kalxas

Alex, is this osgeo-live-6.0-3.iso there for us to test or you need to add anything else to it?

comment:15 Changed 7 years ago by kalxas

Priority: criticalnormal

I confirm that installation now works with osgeo-live-6.0-3.iso. This file should be renamed to osgeo-live-6.0-1.iso before pushed to SF servers.

comment:16 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed

The fixed iso is now uploaded to SourceForge? servers.

Note: See TracTickets for help on using tickets.