Opened 6 years ago

Last modified 6 years ago

#399 reopened defect

[setuptools] easy_install fails with "failed to create process."

Reported by: saultdon Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: setuptools
Cc:

Description

I've installed setuptools from the 64bit OSGeo4W installer and the easy_install command fails every single time with "failed to create process.".

Change History (6)

comment:1 Changed 6 years ago by jef

Priority: criticalmajor

Please provide sample output.

comment:2 in reply to:  1 ; Changed 6 years ago by saultdon

Replying to jef:

Please provide sample output.

failed to create process

comment:3 in reply to:  2 ; Changed 6 years ago by jef

Replying to saultdon:

Replying to jef:

Please provide sample output.

failed to create process

I was thinking of something like:

C:\OSGeo4W64>easy_install pypihello
Searching for pypihello
Reading https://pypi.python.org/simple/pypihello/
Best match: pypiHello 1.2
Downloading https://pypi.python.org/packages/source/p/pypiHello/pypiHello-1.2.zip#md5=01f698cfbdbb8c0b5494c54eb53b065a
Processing pypiHello-1.2.zip
Writing c:\users\jef~1.nor\appdata\local\temp\easy_install-i8hxfg\pypiHello-1.2\setup.cfg
Running pypiHello-1.2\setup.py -q bdist_egg --dist-dir c:\users\jef~1.nor\appdata\local\temp\easy_install-i8hxfg\pypiHello-1.2\egg-dist-tmp-2eicvc
zip_safe flag not set; analyzing archive contents...
Adding pypihello 1.2 to easy-install.pth file

Installed c:\osgeo4~1\apps\python27\lib\site-packages\pypihello-1.2-py2.7.egg
Processing dependencies for pypihello
Finished processing dependencies for pypihello

C:\OSGeo4W64>

As you can see it works fine here.

comment:4 in reply to:  3 Changed 6 years ago by saultdon

Replying to jef:

Replying to saultdon:

Replying to jef:

Please provide sample output.

failed to create process

I was thinking of something like:

C:\OSGeo4W64>easy_install pypihello

C:\OSGeo4W64>

As you can see it works fine here.

Not sure, that's the output I get no matter what I try. Can't even get "easy_install --help" or "--version", "-V", etc.

I've installed using the ez_setup.py script so It's working from my end now too. If you can't reproduce with the 64-bit installer than feel free to close.

comment:5 Changed 6 years ago by jef

Resolution: worksforme
Status: newclosed

comment:6 Changed 6 years ago by saultdon

Resolution: worksforme
Status: closedreopened

I think this is an issue isolated to Windows 8.1 so I'll re-open until someone else can test the OSGeo4W 64bit Installer on Windows 8.1.

I'm getting same result on new PCs with 64bit Windows 8.1 in our office.

Note: See TracTickets for help on using tickets.