Opened 9 years ago

Closed 9 years ago

#870 closed defect (fixed)

Duplicate Legend layer in tcltk

Reported by: clerici Owned by: marisn
Priority: normal Milestone: 6.4.1
Component: Tcl/Tk Version: svn-develbranch6
Keywords: Cc:
CPU: Unspecified Platform: Linux

Description

When two or more legends (of the same or of different maps) are inserted in the GIS Manager through the "Add raster legend layer" button in tcltk GUI, they are correctly displayed, but if a legend is duplicated through the "Duplicated Layer button" an error is output when displaying and everything is frozen (see error.png and error.log). This with GRASS6.5(40448), 6.4, 6.3, 6.2.

Attachments (4)

error.png (8.8 KB) - added by clerici 9 years ago.
errorlog.log (884 bytes) - added by clerici 9 years ago.
error2.png (4.8 KB) - added by clerici 9 years ago.
errorlog2.log (1.4 KB) - added by clerici 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by clerici

Attachment: error.png added

Changed 9 years ago by clerici

Attachment: errorlog.log added

comment:1 Changed 9 years ago by marisn

Milestone: 6.4.06.4.1
Owner: changed from grass-dev@… to marisn
Status: newassigned
Version: unspecifiedsvn-develbranch6

Hopefully fixed in r40450. Please test. Candidate for backporting.

comment:2 Changed 9 years ago by clerici

I uploaded to r40450 but the behaviour is the same with a new error (see error2.png and errorlog2.log).

comment:3 in reply to:  2 Changed 9 years ago by clerici

Sorry, I'm not able to find the way to insert the two attachments. How can I do it?

Changed 9 years ago by clerici

Attachment: error2.png added

Changed 9 years ago by clerici

Attachment: errorlog2.log added

comment:4 Changed 9 years ago by clerici

OK I finally did it. Sorry.

comment:5 Changed 9 years ago by marisn

I'm unable to reproduce Your issue, still possibly r40451 now fixes it. gis.m is a bit tricky (read - copy-paste style hairy code) as gis.m developers don't need Glynn's dead body to do bad things ;)

comment:6 Changed 9 years ago by clerici

With r40451 everything works well.
Thanks

PS. As I'm trying many tcltk features for a small students' manual, I will probably find other (small) disfunctions. Are they of some interest for the developers' team or can be ignored considering that the tcltk GUI will be soon abandoned in favour of the new wxpython GUI?

comment:7 Changed 9 years ago by marisn

Resolution: fixed
Status: assignedclosed

Issue is fixed in 6.5 and 6.4.1 (r43692).

PS. As long as we are shipping gis.m and somebody is using it, we would be happy to get feedback and fix issues.

Note: See TracTickets for help on using tickets.