Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2899 closed defect (fixed)

d.histogram launched from map display toolbar doesn't work

Reported by: annakrat Owned by: grass-dev@…
Priority: blocker Milestone: 7.2.0
Component: wxGUI Version: svn-trunk
Keywords: d.histogram, rendering Cc:
CPU: Unspecified Platform: All

Description

Map display - Analyze map - Create histogram with d.histogram: window appears but there is nothing rendered, no error. Running d.histogram from GUI command line works.

Change History (11)

comment:1 Changed 3 years ago by wenzeslaus

Keywords: rendering added

comment:2 Changed 3 years ago by neteler

I wonder if we still want to keep this old histogram tool in the layer manager menu or just remove it from there? The currently two menu entries are a bit confusing.

comment:3 in reply to:  2 ; Changed 3 years ago by wenzeslaus

Replying to neteler:

I wonder if we still want to keep this old histogram tool in the layer manager menu or just remove it from there? The currently two menu entries are a bit confusing.

I actually prefer the d.histogram-based tool. It does not have the potential for interactivity as the wxPython-based but it uses raster's color table and fills the bars which the wxPython-based currently does not. Also the tools supports more the CLI-Python-GUI convergence. However, I agree that two histogram items are not ideal.

Also, I tested the older revisions and it seems that r65205 broke the histogram (same as #2857).

BTW, the wxPython-based histogram currently does not work for me with wxPython 3.0.2.0 (#2558).

comment:4 in reply to:  3 Changed 3 years ago by mlennert

Replying to wenzeslaus:

Replying to neteler:

I wonder if we still want to keep this old histogram tool in the layer manager menu or just remove it from there? The currently two menu entries are a bit confusing.

I actually prefer the d.histogram-based tool. It does not have the potential for interactivity as the wxPython-based but it uses raster's color table and fills the bars which the wxPython-based currently does not.

How difficult would it be to implement this in the wx version ? I agree that this is a very nice feature, even though more generally I prefer the new tool for its interactivity, but also, for example for the capacity to show several histograms at once.

Also the tools supports more the CLI-Python-GUI convergence.

Yes. That is an important point. Would it be possible to isolate the wx version as a g.gui.histogram tool and then allow directly drawing the results without interaction (i.e. with GRASS_RENDER_IMMEDIATE=TRUE) ?

However, I agree that two histogram items are not ideal.

Also, I tested the older revisions and it seems that r65205 broke the histogram (same as #2857).

BTW, the wxPython-based histogram currently does not work for me with wxPython 3.0.2.0 (#2558).

As long as #2558, please do not remove d.histogram. It's been the only way to do histograms for me for quite a while...

comment:5 Changed 3 years ago by wenzeslaus

Milestone: 7.0.47.1.0
Priority: normalblocker

Replying to mlennert:

As long as #2558, please do not remove d.histogram. It's been the only way to do histograms for me for quite a while...

There is also the histogram with legend, but since we apparently can't rely on the wxPython one, I'm raising the priority of this one. The fallback option would be to revert r65205 but it might not be possible.

comment:6 in reply to:  5 ; Changed 3 years ago by mlennert

Replying to wenzeslaus:

Replying to mlennert:

As long as #2558, please do not remove d.histogram. It's been the only way to do histograms for me for quite a while...

There is also the histogram with legend, but since we apparently can't rely on the wxPython one, I'm raising the priority of this one. The fallback option would be to revert r65205 but it might not be possible.

Does anyone have any idea where this issue comes from ? d.histogram's last change dates from 16 months ago and I've used it successfully since, so the issue is probably linked to some change in the wxgui, but what ?

comment:7 in reply to:  6 Changed 3 years ago by wenzeslaus

Replying to mlennert:

Does anyone have any idea where this issue comes from ? d.histogram's last change dates from 16 months ago and I've used it successfully since, so the issue is probably linked to some change in the wxgui, but what ?

r65205, see the comments above or #2857. You can use something like svn update -r65204 to check it.

comment:8 Changed 3 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:9 Changed 3 years ago by martinl

In 68905:

d.histogram launched from map display toolbar doesn't work (see #2899)

comment:10 Changed 3 years ago by martinl

Resolution: fixed
Status: newclosed

In 68906:

d.histogram launched from map display toolbar doesn't work (fixes #2899) (merge r68905 from trunk)

comment:11 Changed 3 years ago by wenzeslaus

Tested both in trunk and 7.2 on Linux. Thanks!

Note: See TracTickets for help on using tickets.