Opened 4 years ago

Closed 4 years ago

#2588 closed defect (fixed)

wxGUI digitizer: error when adding a new column

Reported by: mlennert Owned by: grass-dev@…
Priority: critical Milestone: 7.0.0
Component: wxGUI Version: svn-releasebranch70
Keywords: digitizer crash add column Cc:
CPU: Unspecified Platform: Unspecified

Description

  • In wxGUI Display Manager, chose Digitize -> New map
  • Try to add a new column to the new map:
ATTENTION: Unable to open vector map <test1@user1> on level 2. Try to
           rebuild vector topology with v.build.
ERREUR :Unable to open vector map <test1@user1>
Traceback (most recent call last):
  File "/data/home/mlennert/SRC/GRASS/grass-7.0.0RC2/dist.x86_64-unknown-linux-gnu/scripts/v.db.addcolumn", line 88, in <module>
    main()
  File "/data/home/mlennert/SRC/GRASS/grass-7.0.0RC2/dist.x86_64-unknown-linux-gnu/scripts/v.db.addcolumn", line 84, in main
    grass.vector_history(map)
  File "/data/home/mlennert/SRC/GRASS/grass-7.0.0RC2/dist.x86_64-unknown-linux-gnu/etc/python/grass/script/vector.py", line 145, in vector_history
    run_command('v.support', map=map, cmdhist=os.environ['CMDLINE'])
  File "/data/home/mlennert/SRC/GRASS/grass-7.0.0RC2/dist.x86_64-unknown-linux-gnu/etc/python/grass/script/core.py", line 375, in run_command
    return handle_errors(returncode, returncode, args, kwargs)
  File "/data/home/mlennert/SRC/GRASS/grass-7.0.0RC2/dist.x86_64-unknown-linux-gnu/etc/python/grass/script/core.py", line 310, in handle_errors
    returncode=returncode)
grass.exceptions.CalledModuleError: Module run None ['v.support', 'map=test1@user1', 'cmdhist=v.db.addcolumn "--q" "map=test1@user1" "layer=1" "columns=tt1 integer"'] ended with error
Process ended with non-zero return code 1. See errors in the (error) output.

Change History (6)

comment:1 Changed 4 years ago by mlennert

A bit more info:

  • the column actually gets created
  • I can reproduce this with any existing map by just putting it into editing mode and then trying to add a column

comment:2 Changed 4 years ago by annakrat

I think v.support doesn't need to open the vector on level 2. Changing it to level 1 solves this issue. Any opinion on that?

comment:3 in reply to:  2 Changed 4 years ago by mlennert

Replying to annakrat:

I think v.support doesn't need to open the vector on level 2. Changing it to level 1 solves this issue. Any opinion on that?

I don't see any reason why v.support would need topology.

comment:4 Changed 4 years ago by annakrat

If there are no objections, I will commit it tomorrow. I just want to avoid breaking v.support because of my insufficient knowledge of vector library...

comment:5 Changed 4 years ago by annakrat

Done in r64603 and r64604. Moritz, please confirm that it fixed the issue and close this, thanks.

comment:6 in reply to:  5 Changed 4 years ago by mlennert

Resolution: fixed
Status: newclosed

Replying to annakrat:

Done in r64603 and r64604. Moritz, please confirm that it fixed the issue and close this, thanks.

Yes, this fixes it for me. And rapid tests of v.support have not shown any bad consequences. Closing.

Thanks a lot !

Note: See TracTickets for help on using tickets.