Opened 4 years ago

Closed 4 years ago

#2482 closed defect (fixed)

g.gui.iclass: temp maps are not erased when tool is closed

Reported by: mlennert Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-releasebranch70
Keywords: g.gui.iclass temporary maps Cc:
CPU: Unspecified Platform: Unspecified

Description

After several runs of g.gui.iclass, each time closing the tool as by clicking the "Close" button, my mapset is now cluttered with the temporary maps created by the tool:

> g.list rast -p
----------------------------------------------
raster fichiers disponibles dans le jeu de données <classif_par_objet> :
bati_15039.1        class_3_15039.2     seg_pan             test_maxlik
bati_15961.1        class_4_15039.3     sol_nu_15039.0      veg_basse_15039.1
bati_15961.2        class_5_15039.4     sol_nu_15961.0      veg_basse_15961.1
class_1_15039.0     eau_15039.0         sol_nu_15961.1      veg_haute_15039.0
class_2_15039.1     eau_15961.0         test                veg_haute_15961.0

Apparently the clean up procedures do not work correctly.

This is on trunk and 70release.

Change History (3)

comment:1 Changed 4 years ago by annakrat

Please try trunk r62696. I was not able to reproduce it but hopefully this will fix it. If it segfaults, there is no way I know of to do the cleanup.

comment:2 Changed 4 years ago by annakrat

Any update on this one?

comment:3 in reply to:  2 Changed 4 years ago by mlennert

Resolution: fixed
Status: newclosed

Replying to annakrat:

Any update on this one?

Sorry, this a bit off my radar. Now, once I quit the tool the temp maps are erased. It can still be a bit odd to see these temp maps in your mapset while you're working on the creation of training areas (to me at least it sometimes happens that I need to go back to the normal layer manager and map display (or to the command line) while I'm digitizing and then I suddenly have all these temps maps in my map list), but I don't know if this is avoidable and if they are erased after leaving the tool as is the case now, I can live with that.

Thanks a lot, Anna !

Closing this ticket for now.

Note: See TracTickets for help on using tickets.