Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#2353 closed enhancement (fixed)

v.univar says type not supported instead of column does not exist

Reported by: wenzeslaus Owned by: grass-dev@…
Priority: trivial Milestone: 7.2.0
Component: Database Version: svn-trunk
Keywords: v.univar, vector, messages Cc:
CPU: Unspecified Platform: All

Description

G7:v.univar with column which does not exists reports low-level message "no such column" tow times together with some other things and than gives GRASS standard error "Column type not supported". It should end after the first try, not print the low-level (detailed) messages (if possible, should go to debug), and print the correct error message ""Column does not exist" (or "not found"?).

v.univar map=bridges column='YEAR_BUILTTT'
DBMI-SQLite driver error:
Error in sqlite3_prepare():
SELECT cat, YEAR_BUILTTT FROM bridges
no such column: YEAR_BUILTTT

DBMI-SQLite driver error:
Error in sqlite3_prepare():
SELECT cat, YEAR_BUILTTT FROM bridges
no such column: YEAR_BUILTTT

ERROR: Column type not supported

I was not looking to the source code.

Change History (3)

comment:1 Changed 3 years ago by jrobparsons

Can not duplicate.

GIS GRASS 7.1.SVN Build Date: 2015-07-03 Python: 2.7.4 wxPython: 2.8.12.1 Windows 7

(Tue Jul 07 22:01:45 2015) v.univar map=bridges column=YEAR_BUILTTT ERROR: Column <YEAR_BUILTTT> not found in table <bridges> (Tue Jul 07 22:01:47 2015) Command finished (2 sec)

GIS GRASS 7.1.SVN (64bit) Build Date: 2015-06-25 Python: 2.7.6 wxPython: 2.8.12.1 Ubuntu 14.04 LTS

(Tue Jul 7 22:15:39 2015) v.univar map=bridges column=YEAR_BUILTTT ERROR: Column <YEAR_BUILTTT> not found in table <bridges> (Tue Jul 7 22:15:40 2015) Command finished (0 sec)

comment:2 Changed 3 years ago by wenzeslaus

Resolution: fixed
Status: newclosed

I can't reproduce it either:

> v.univar map=hospitals column='ANGLE'
...
minimum: 0
maximum: 1
range: 1
sum: 133
...
> v.univar map=hospitals column='XXX'
ERROR: Column <XXX> not found in table <hospitals>

I searched logs (db lib and v.univar) and it was fixed in r63889 by martinl (backported in r63891). Thanks, Martin!

Closing as fixed.

comment:3 Changed 2 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

Note: See TracTickets for help on using tickets.