Opened 9 years ago

Closed 3 years ago

#1203 closed enhancement (duplicate)

explain command mapping to wxGUI menus

Reported by: timmie Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: Docs Version: unspecified
Keywords: module synopsis, toolboxes Cc:
CPU: Unspecified Platform: All

Description (last modified by hamish)

Hello, there was nice PDF file created by Hamish that shows which grass command (module) is mapped to which menu in the wxGUI.

I cannot find it on the following doc pages:

It would be really helpful to have it included in the docs at a prominent location.

Thanks in advance, Timmie

Change History (15)

comment:1 in reply to:  description ; Changed 9 years ago by hellik

Component: DefaultWebsite
Platform: UnspecifiedAll
Type: defectenhancement

Replying to timmie:

Hello, there was nice PDF file created by Hamish that shows which grass command (module) is mapped to which menu in the wxGUI.

I cannot find it on the following doc pages:

It would be really helpful to have it included in the docs at a prominent location.

Do you mean this one: GRASS 6.4.0 Command list? http://grass.osgeo.org/gdp/grassmanuals/grass64_module_list.pdf

it's linked in the moment on the first page of http://grass.osgeo.org/ under # 17 Sep 2009: GRASS 6.4.0 module synopsis published - A list of all modules with GUI menu locations

Helmut

Thanks in advance, Timmie

comment:2 in reply to:  1 ; Changed 9 years ago by timmie

Replying to hellik:

Replying to timmie:

Hello, there was nice PDF file created by Hamish that shows which grass command (module) is mapped to which menu in the wxGUI.

Do you mean this one: GRASS 6.4.0 Command list? http://grass.osgeo.org/gdp/grassmanuals/grass64_module_list.pdf

Yes, I am referencing to that document. Please add it to the GRASS documentation. This is also linked to #645 http://trac.osgeo.org/grass/ticket/645

Using the GUI, I often find myself lost when trying to find certain modules!

comment:3 in reply to:  2 Changed 9 years ago by hellik

Replying to timmie:

Replying to hellik:

Replying to timmie:

Hello, there was nice PDF file created by Hamish that shows which grass command (module) is mapped to which menu in the wxGUI.

Do you mean this one: GRASS 6.4.0 Command list? http://grass.osgeo.org/gdp/grassmanuals/grass64_module_list.pdf

Yes, I am referencing to that document. Please add it to the GRASS documentation. This is also linked to #645 http://trac.osgeo.org/grass/ticket/645

Using the GUI, I often find myself lost when trying to find certain modules!

the linked pdf should be updated to the GRASS64-release of september 2010.

in the upcoming GRASS6.4.1 there are 3 improvements for finding modules in the wxgui:

(1) there is the search-module-tab in the wxgui-layer manager (just as in grass65) (2) in the command console tab in the wxgui the search module engine can be activated for a quick launch of a certain module (3) in the command console tab you can type for example r.o and you jump automagically to all raster output-commands (r.out.xxx) and can choose the desired command

I'm starting the most time a module by option (3), it's a very fast way to avoid searching a module in the wx-pulldown.menues.

HTH Helmut

comment:4 Changed 9 years ago by timmie

Yes, I also use the option 3) a lot.

But the suggested addition of the PDF to the docs would be a nice complementary.

Thanks for looking into this.

comment:5 Changed 9 years ago by hamish

Keywords: synopsis added

Hi,

fyi the tools/module_synopsis.sh script which makes the PDF also produces a html version:

"$GISBASE/docs/html/module_synopsis.html"

it needs at least a dummymapset to run. (and so could easily create translated results)

see also "$GISBASE/etc/wxpython/gui_modules/menudata.py"

Hamish

comment:6 Changed 9 years ago by timmie

I couldn't find that page in file:///usr/lib/grass64/docs/html/

on Ubuntu 10.10 with grass64.

OSGEO4W doesn't install any docs at all...

comment:7 in reply to:  5 Changed 7 years ago by hamish

Component: WebsiteDocs
Keywords: module added
Milestone: 6.4.16.5.0

Replying to hamish:

fyi the tools/module_synopsis.sh script which makes the PDF also produces a html version:

"$GISBASE/docs/html/module_synopsis.html"

it needs at least a dummymapset to run. (and so could easily create translated results)

see also "$GISBASE/etc/wxpython/gui_modules/menudata.py"

Replying to timmie:

I couldn't find that page in file:///usr/lib/grass64/docs/html/

it isn't generated automatically (currently), you need to run it by hand. (same for make pdfdocs which seems to be on holiday right now)

Hamish

comment:8 Changed 6 years ago by hamish

btw, the HTML version of the same:

http://grass.osgeo.org/gdp/grassmanuals/grass64_module_list.html

(the relative link to "../../images/grasslogo.gif" is broken since the website move)

Hamish

comment:9 Changed 6 years ago by hamish

Description: modified (diff)

comment:10 Changed 6 years ago by neteler

I tried in order to update the server cronjob(s) but:

[neteler@oboe grass64]$ sh tools/module_synopsis.sh
You must be in GRASS GIS to run this program.

The script should create itself the virtual GRASS session, e.g. using demolocation. As soon that's implemented I can activate it on http://grass.osgeo.org

comment:11 in reply to:  10 Changed 6 years ago by hamish

Replying to neteler:

I tried in order to update the server cronjob(s) but:

> [neteler@oboe grass64]$ sh tools/module_synopsis.sh
> You must be in GRASS GIS to run this program.

The script should create itself the virtual GRASS session, e.g. using demolocation. As soon that's implemented I can activate it on http://grass.osgeo.org

Hi,

fwiw I'm not really too motivated in having it run automatically since I do a bit of manual cleanup and by-hand tuning to get the final product anyway. For 6.4.3 it needs an update, and I was planning to do the same again.

If it were to run automatically, I'd think it mildly better to make a generic GRASS_BATCH_JOB run it. But it only needs to be run about once or twice a year, so a cron job is probably overkill (IMO).

(the relative link to "../../images/grasslogo.gif" is broken since the website move)

that's now fixed, thanks.

regards, Hamish

comment:12 Changed 5 years ago by wenzeslaus

Keywords: toolboxes added

What is the status of this ticket? What was fixed or added and what is not working?

In any case, for GRASS 7 (trunk), this is seems to be a duplicate of #645 which now probably depends on #2142.

comment:13 in reply to:  12 Changed 4 years ago by wenzeslaus

Milestone: 6.5.07.1.0

Moving milestone to 7.1.

I'm still interested in what is the status of this ticket, what was fixed or added, what is not working and most importantly, what is the desired result.

comment:14 Changed 3 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:15 Changed 3 years ago by wenzeslaus

Resolution: duplicate
Status: newclosed

Closing as duplicated of #645. Please follow up there with wishes for the desired solution.

Note: See TracTickets for help on using tickets.