Opened 7 years ago

Closed 3 years ago

#594 closed defect (duplicate)

geos turns 'POLYGON EMPTY' into 'POLYGON(EMPTY)'

Reported by: cdestigter Owned by: geos-devel@…
Priority: major Milestone: 3.6.1
Component: Default Version: 3.3.3
Severity: Unassigned Keywords:
Cc:

Description

I wouldn't mind except that in postgis, ST_IsEmpty('POLYGON(EMPTY)') ==> False.

Using the geodjango bindings:

    >>> from django.contrib.gis import geos
    >>> g = geos.GEOSGeometry('POLYGON EMPTY')
    >>> print g.wkt, g.hex
    '01030000000100000000000000'

    >>> g = geos.GEOSGeometry('POLYGON(EMPTY)')
    >>> print g.wkt, g.hex
    '01030000000100000000000000'

Change History (9)

comment:1 Changed 7 years ago by cdestigter

I filed a postgis bug for that ST_IsEmpty issue: http://trac.osgeo.org/postgis/ticket/2015

comment:2 Changed 7 years ago by cdestigter

Even worse, I can't even use hex to create the geometry, which means I can't work around the bug:

    >>> geos.GEOSGeometry('010300000000000000').hex
    '01030000000100000000000000'

comment:3 Changed 7 years ago by strk

Milestone: 3.3.63.3.7

I see the postgis side has been fixed (but only 2.1.x) Have a patch for the GEOS side of it ?

comment:4 Changed 6 years ago by strk

Milestone: 3.3.73.3.x

comment:5 Changed 6 years ago by robe

Milestone: 3.3.93.5.0

oh no the empty typed space again with no patch to support it. Push.

comment:6 Changed 4 years ago by robe

Milestone: 3.5.03.6.0

comment:7 Changed 3 years ago by strk

Milestone: 3.6.03.7.0

Ticket retargeted after milestone closed

comment:8 Changed 3 years ago by sirsigurd

looks like a duplicate of #680

comment:9 Changed 3 years ago by strk

Milestone: 3.7.03.6.1
Resolution: duplicate
Status: newclosed

Yep, confirmed, thanks for checking.

Note: See TracTickets for help on using tickets.