Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#6933 closed task (fixed)

Deprecation of older versions of Planet Labs scenes API

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.2.1
Component: OGR_SF Version: unspecified
Severity: normal Keywords: plscenes
Cc: warmerdam

Description

Planet Labs "v0" api will be removed at the end of this month (June).

The "v1 catalog api" was never formally released, so it is not desirable that it is used

Actions :

  • in trunk, remove all traces of v0 and v1 API
  • in branches/2.2, remove all traces of v0 API. And mention in the doc that the v1 API is deprecated and users should migrate to Data V1 API instead.

Change History (2)

comment:1 Changed 6 months ago by Even Rouault

Resolution: fixed
Status: assignedclosed

In 39214:

PLScenes: remove support for V0 and V1 API. Only Data V1 is kept (fixes #6933)

comment:2 Changed 6 months ago by Even Rouault

In 39215:

PLScenes: remove support for V0. Deprecate V1 API. Only Data V1 is supported (fixes #6933)

Note: See TracTickets for help on using tickets.