Opened 4 years ago

Closed 4 years ago

#5170 closed defect (fixed)

vsicache doesn't work on 32bit binaries when file size is over 2GB

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.9.3
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Description

Reported in http://lists.osgeo.org/pipermail/gdal-dev/2013-July/036741.html

GDAL 1.9.2 fails to read (large?) overview files if
    VSI_CACHE=TRUE
    VSI_CACHE_SIZE=1000000
The problem is described here: http://hub.qgis.org/issues/8356.
I just guess, that overview file keeps overview headers scattered over
the file and VSI fails to set offset, 17891712530 in this case, over
some limit.

Could it be some hardcoded limit in VSI subsystem? Or just int used
for offset instead of long? Is it easy to fix? Should I create a new
ticket?

Until it gets fixed in GDAL, how can we easily enable the VSI cache
for OGR and disable it for GDAL?

Radim

Change History (1)

comment:1 Changed 4 years ago by Even Rouault

Milestone: 1.9.3
Resolution: fixed
Status: newclosed

Fix commited in trunk (r26216), branches/1.10 (r26217) and branches/1.9 (r26218)

Note: See TracTickets for help on using tickets.