Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#5089 closed defect (fixed)

OGR Layer Algebra Mixed Fields If Precreated

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SF Version: unspecified
Severity: normal Keywords: layer algebra
Cc: Ari Jolma

Description

When using OGRLayer::Intersection() with an output layer that has the fields precreated, then handling of fields from the method layer is mixed up.

The problem is demonstrated in the second test of algebra_intersection() in autotest/ogr/ogr_layer_algebra.py after the patch. The fix is in set_result_schema() in ogrlayer.cpp.

Change History (3)

comment:1 Changed 4 years ago by warmerdam

Resolution: fixed
Status: newclosed

Test added in trunk (r26014), and bug fixed in trunk (r26013).

Fixed in 1.10 branch (r26016).

comment:2 Changed 4 years ago by warmerdam

Note, this affects all the layer algebra operations similarly.

comment:3 in reply to:  1 Changed 4 years ago by Ari Jolma

Replying to warmerdam:

Test added in trunk (r26014), and bug fixed in trunk (r26013).

Fixed in 1.10 branch (r26016).

Thanks.

Note: See TracTickets for help on using tickets.