Opened 7 years ago

Closed 7 years ago

#4088 closed defect (fixed)

gdal_fillnodata.py sometimes fails due to use of small-tiff for mask

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone: 1.8.1
Component: Algorithms Version: 1.8.0
Severity: normal Keywords:
Cc:

Description

Hello,

I'm facing a problem related to BigTiff? support in experimental FWTools3 on Linux. BigTiff? support works fine with all compiled programs (e.g. gdal_translate, gdalwarp) but not with the python script gdal_fillnodata.py. For instance, executing:

  gdal_fillnodata.py -md 10 unfilled.tif filled.tif

is terminated by the message:

  ERROR 1: TIFFAppendToStrip:Maximum TIFF file size exceeded
  ERROR 1: An error occured while writing a dirty block
  ERROR 1: TIFFAppendToStrip:Maximum TIFF file size exceeded
  ...

I have tested with versions 3.0.2 and 3.0.6 under 32 and 64 bit Ubuntus.

Any hint what is going wrong?

--

It turns out the problem is that the temporary file created by the GDALFillNodata() function is created with LZW compression but not forced to BIGTIFF and it is overflowing the small tiff file.

Change History (1)

comment:1 Changed 7 years ago by warmerdam

Milestone: 1.8.1
Resolution: fixed
Status: newclosed

Changed to use BIGTIFF=IF_SAFER option in trunk (r22395) and 1.8 (r22896).

Note: See TracTickets for help on using tickets.