Opened 7 years ago

Closed 7 years ago

#3946 closed defect (fixed)

ASRP with polar stereographic

Reported by: morabit Owned by: warmerdam
Priority: normal Milestone: 1.8.1
Component: GDAL_Raster Version: 1.8.0
Severity: normal Keywords: SRP
Cc: Even Rouault

Description

Hi All,
We have some problems loading an ASRP dataset with GDAL API.
The dataset is loaded successfully but a single specific .IMG file fails with the following error message:

GNC00108.IMG not recognised as a supported file format.

Runnging the gdalinfo utility on this file we have the following report:

ERROR 1: Polar cases are not handled by SRP driver
ERROR 4: `F:\Dati\GeoRef\Mpf\Input\ASRP\ASRP-1-5M-GNC-V.2-GSGS-NorthWorld\ASRP\GNC001\GNC00108.IMG' not recognised as a suppo
rted file format.

gdalinfo failed - unable to open 'F:\Dati\GeoRef\Mpf\Input\ASRP\ASRP-1-5M-GNC-V.2-GSGS-NorthWorld\ASRP\GNC001\GNC00108.IMG'.



So, it seems that this specific driver doesn't support the polar stereographic projection.
Is this a feature or is ths a bug?
In the first case, it's possible to support it in future releases of the srp driver or there's a particular reason to this limitation ?

Thank You for Your attention

Bruno M.

Change History (7)

comment:1 Changed 7 years ago by warmerdam

Cc: Even Rouault added
Keywords: SRP added

Bruno,

I suspect the problem is either that we did not have an example file, or that it was not of immediate interest with regard to the needs of the developer. Would it be possible to provide the problem sample tile? It could be held confidentially just for development and testing purposes if necessary.

Even any thoughts?

comment:2 Changed 7 years ago by Even Rouault

Frank,

I was wondering why you asked me the question as you are the author of the SRP driver, but I can see this is a copy&paste from the ADRG driver where the same limitation exists ;-)

The main reason was lack of interest to handle this case mainly due to lack of testing data for those remote and cold regions of the world ;-)

Hopefully (should probably be confirmed by a look at the ASRP, ADRG and CADRG specs) the handling of those polar cases should be similar to what has been added in the NITF driver, in nitfdataset.cpp, below the following comment :

/* -------------------------------------------------------------------- */
/*      Does this look like a CADRG polar tile ? (#2940)                */
/* -------------------------------------------------------------------- */

at least as far as the projection string is concerned

comment:3 Changed 7 years ago by morabit

Hi,

thank you for your quick reply.

We attach the ASRP tile that shows the reported problem for polar cases. Given the size of then .IMG file (about 7.3 Mb), it's been zipped and splitted with the free 7-Zip application; please notify us if you have any problems to extract the original file. It is intended that the provided data is striclty confidential. Thank you very much for your attention.

Best regards

Bruno M.

comment:4 Changed 7 years ago by warmerdam

Status: newassigned

Confidential data attachments deleted - there is no way to keep the confidential when attached to a public ticket. I have downloaded them and will treat my copy as confidential.

comment:5 Changed 7 years ago by warmerdam

It turns out I really need the .GEN file that corresponds to the .IMG file. Please feel free to email it directly to me at warmerdam@….

comment:6 in reply to:  5 Changed 7 years ago by morabit

Replying to warmerdam:

It turns out I really need the .GEN file that corresponds to the .IMG file. Please feel free to email it directly to me at warmerdam@….

Ok, I've just sent to the above email address the .requested .GEN file

comment:7 Changed 7 years ago by warmerdam

Milestone: 1.8.1
Resolution: fixed
Status: assignedclosed

I had limited success with the ASRP documentation which explained that the poles are in an Azimuthal Equidistant projection but provided a somewhat esoteric set of equations to map between pixel/line and lat/long coordinates. I was reasonably successful applying an AE projection and manually deriving the geotransform from the actual image.

The update is in trunk (r21639) and 1.8 (r21640).

The changes include a case for the southern pole but this is untested. The results seem to be accurate to within a couple of kilometers at least based on check pointing of Alert and 80N edge.

Note: See TracTickets for help on using tickets.