Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#1428 closed defect (duplicate)

Oblique_ vs Double_Stereographic

Reported by: werchowyna@… Owned by: warmerdam
Priority: highest Milestone:
Component: OGR_SRS Version:
Severity: major Keywords:
Cc: etourigny

Description (last modified by etourigny)

Data data created with ESRI software, projected in EPSG 3120,2172-2174,
have their PROJECTION specified as Double_Stereographic (eg. [1]).
However, GDAL and dependent software use
PROJECTION["Oblique_Stereographic"] for these systems. This leads to
mismatches during data exchange, eg. v.in.ogr claims the shapefile
projected in 2174, created with ESRI software, does not match a GRASS
location set up using the same code - due to unknown projection name
Double_Stereographic [2].

I don't know for other 13 sterea projections [3], but according to [4]
ESRI's Double_Stereographic is the same as GDAL's
Oblique_Steregraphic, and that seems to make sense for 3120,2171-2174.

Should Double_Stereographic be intepreted as Oblique_Steregraphic by
GDAL and friends?

Please read Paul Kelly's comments on grass-dev:
http://www.nabble.com/Re%3A--GRASS-user--problem-with-vi.in.ogr-tf2934543.html

The discussion started on grass-user:
http://www.nabble.com/problem-with-vi.in.ogr-tf2931526.html

[1]
Layer SRS WKT:
PROJCS["PUWG_65_Strefa_IV",
    GEOGCS["GCS_Pulkovo_1942",
        DATUM["Pulkovo_1942",
            SPHEROID["Krasovsky_1940",6378245.0,298.3]],
        PRIMEM["Greenwich",0.0],
        UNIT["Degree",0.0174532925199433]],
    PROJECTION["Double_Stereographic"],
    PARAMETER["False_Easting",3703000.0],
    PARAMETER["False_Northing",5627000.0],
    PARAMETER["Central_Meridian",16.67222222222222],
    PARAMETER["Scale_Factor",0.9998],
    PARAMETER["Latitude_Of_Origin",51.67083333333333],
    UNIT["Meter",1.0]]

[2]
No projection name! Projection parameters likely to be meaningless.
A datum name S-42 (Pulkovo_1942) was specified without transformation
parameters.

[3]
$ grep -c "proj=sterea " /usr/local/share/proj/epsg
18
(substract 4 deprecated of them)

[4]
http://udig.refractions.net/docs/api-geotools/org/geotools/ct/proj/Stereographic.html

Change History (5)

comment:1 Changed 6 years ago by etourigny

Cc: etourigny added
Description: modified (diff)

comment:2 in reply to:  description Changed 6 years ago by peifer

Replying to werchowyna@…:

Should Double_Stereographic be intepreted as Oblique_Steregraphic by GDAL and friends?

I's say: Yes. When looking at it at the time, I came to the conclusion that: Double_Stereographic = Oblique_Stereographic = sterea, see my related ticket #2869

comment:3 Changed 6 years ago by etourigny

Version: 1.4.0

According to this ticket, the following should also be changed.

changeset r21627 : morphFromESRI(): Remap Stereographic to OBLIQUE_STEREOGRAPHIC to get correct round-tripping (for example for EPSG:3844)

Can you provide a test file in ESRI WKT format so I can get this fixed?

comment:4 Changed 6 years ago by etourigny

Resolution: duplicate
Status: newclosed

Closing this bug as duplicate of #4267, which has more information.

peifer: please add any ESRI files there

comment:5 in reply to:  4 Changed 6 years ago by peifer

Replying to etourigny:

peifer: please add any ESRI files there

Done. Hermann

Note: See TracTickets for help on using tickets.