Opened 7 years ago

Closed 5 years ago

#433 closed defect (fixed)

Map tips are broken in branches/2.2

Reported by: trevorwekel Owned by: madair
Priority: P2 Milestone: Future
Component: Widgets Version: 2.2 - RC1
Severity: Major Keywords:
Cc: Browser: All
External ID: Operating System: All
state: New

Description

The map tips no longer work. Hovering over a feature results in an ajax error about an undefined object.

On line 154 of Maptip.js "offsets" no longer exists

  this.mapOffset = map._oDomObj.offsets;

Which breaks line 261

this.oMapTipPosition = this.oMapTipPosition.add(this.mapOffset[0], this.mapOffset[1]);

Change History (4)

comment:1 Changed 7 years ago by madair

Trevor,

I found this was broken in trunk but working correctly in Fusion-2.2 branch. Can I get you to verify which version you are testing with? But mostly checking the version of Jx that you are testing with.

The problem is due to a change in the underlying Jx object. With Jx2 it uses:

this.mapOffset = map._oDomObj.offsets;

whereas in Jx3 we need to use:

this.mapOffset = map._oDomObj.getOffsets();

and the offsets are in .x and .y properties

comment:2 Changed 7 years ago by trevorwekel

We are using fusion/branches/fusion-2.2. As near as I can tell, http://trac.osgeo.org/fusion/log/branches/fusion-2.2/lib/jxlib.uncompressed.js contains the getOffsets() function but I am unable to find the ".offsets" property. Firefox also shows the function but not the property.

comment:3 Changed 7 years ago by madair

it appears that the same patch works in the 2.2 branch so it is fixed at rev [2336]

comment:4 Changed 5 years ago by jng

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.