wiki:FdoPostgreSQLNotes

FDO PostgreSQL Provider Notes

The PostgreSQL Provider was introduced in FDO 3.5. The minimum supported client software versions are:

  • MapGuide Open Source 2.2
  • AutoCAD Map 3D 2011
  • FDOToolbox 0.9.3 (?)

The provider is known to work with: <!-- please update this section -->

  • PostgreSQL Server 8.3 to 8.4
  • PostGIS 1.3 to 1.5
    • geometry types only
    • GEOS=3.0 to 3.2
    • PROJ 4.7

See older PostGIS Provider for an alternative with AutoCAD Map 3D 2008–2010 and MapGuide 2.0–2.1.

System Path

You must have your PostgreSQL\ bin directory in your system path, look for libpg.dll (windows)

Connection Parameters

When you attempt to establish a connection with the PostgreSQL provider, you will need to fill in a number of parameters, described below:

Username::

Your PostgreSQL username (see #647)

Password::

Your postgresql password

Service::

A connection string in the format "host[:port]", for example "localhost" (assuming default port of 5432) or "192.168.123.22:5436"

Datastore::

This is the PostgreSQL database on the host

Open Tickets

#698
PostgreSQL: Z-coordinate (3D) not supported and misrepresented in AutoCAD Map3D
#836
"Copying thirdparty dlls" postbuild step for PostgreSQL provider fails on first build from command line
#899
PostgreSQL provider does not support other schema than public when fdometadata is activated
#928
QueryFeatures Request fails when there are CurvePolygons in PostGIS table

Last modified 7 years ago Last modified on Jan 10, 2011 2:47:16 AM