Opened 15 years ago

Closed 14 years ago

Last modified 13 years ago

#825 closed bug (duplicate)

Layers can't be quickly rearranged without upsetting the order

Reported by: gburns Owned by: nobody
Priority: major: does not work as expected Milestone:
Component: Project Loading / Saving Version: Trunk
Keywords: layer, layer set, order Cc: msieczka
Must Fix for Release: Yes Platform: All
Platform Version: Awaiting user input: no

Description

When you use a Layer Set and try to rearrange the layers within the set (ie in alphabetical order), under certain conditions the layers are rearranged in an unexpected way. This only occurs when you move the layer too fast. eg. if you have a list of layers:

B

C

D

A

and you move A upwards fairly slowly to the top, the new list will be in order. However, if you move it too fast, the other layers get out of order. This effect may not occur in a short list.

The problem occurs because when you move a layer, it swaps around, in real time, with every other layer it comes across. If you move too fast, this swapping doesn’t happen correctly, and layers get swapped which shouldn’t. Other software that I have used doesn’t do the rearranging until you let go of the mouse.

Also, it is not a good idea when a layer is being moved, to have sets open up as they are passed. If you try to move a layer past a set with 100 items, the 100 items suddenly appear before you, and you have to pass all those layers as well. I suggest that when layers are moved, they pass sets without opening them.

This is a major problem in trying to maintain layers in order. You might spend 10 minutes putting 100 items in order in several different sets, but if you move one layer too fast, the whole lot get out of order.

Change History (6)

comment:1 by pcavallini, 15 years ago

Milestone: Version 0.9.1

comment:2 by paulp575, 15 years ago

UPDATE: Just installed v0.10.0 on a computer with Windows XP with SP2 installed and the problem still exists!

comment:3 by paulp575, 15 years ago

Component: Map LegendProject Loading / Saving
Must Fix for Release: NoYes
Platform: OS XWindows
Platform Version: 10.4.10XP PRO w/SP2
Priority: minor: annoyance or enhancementmajor: does not work as expected

UPDATE: Just installed v0.11.0 on a computer running Windows XP Pro with SP2 installedand the problem still exists!

in reply to:  3 comment:4 by msieczka, 14 years ago

Cc: msieczka added
Platform: WindowsAll
Platform Version: XP PRO w/SP2
Type: defectbug

Replying to paulp575:

UPDATE: Just installed v0.11.0 on a computer running Windows XP Pro with SP2 installedand the problem still exists!

I confirm the bug in SVN trunk r9205 on Debian testing amd64.

comment:5 by homann, 14 years ago

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #699, so I close it. Chanegs has been made since r9547, please try it out.

comment:6 by (none), 13 years ago

Milestone: Version 1.0.0

Milestone Version 1.0.0 deleted

Note: See TracTickets for help on using tickets.