Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#808 closed bug (fixed)

fails to create ".gislock" on Windows

Reported by: msieczka Owned by: marcopx
Priority: major: does not work as expected Milestone:
Component: GRASS Version: Trunk
Keywords: Cc: neteler
Must Fix for Release: Yes Platform: Windows
Platform Version: Awaiting user input: no

Description

QGIS 0.9 on Windows (XP, 2000) fails to create the ".gislock" file in the opened mapset. Then it complains closing mapset:

Cannot close mapset. Cannot remove mapset lock: d:/grassdata/spearfish60/user1/.gislock

I can't reproduce this behaviour in QGIS on Ubuntu Dapper, using 0.9.1 SVN 7389.

Change History (16)

comment:1 Changed 14 years ago by msieczka

Platform: DebianWindows

comment:2 Changed 14 years ago by neteler

Should this be reported to GRASS-trac?

comment:3 Changed 14 years ago by msieczka

Cc: neteler@… added

Markus

I don't know. Why do you think this a GRASS issue, not QGIS?

comment:4 Changed 14 years ago by neteler

Cc: neteler added; neteler@… removed

OK. Could you enable debugging output? Maybe then we see where it originates from.

Markus

comment:5 in reply to:  4 Changed 14 years ago by msieczka

Replying to neteler:

OK. Could you enable debugging output? Maybe then we see where it originates from.

I'm affraid I can't. That was on Windows. I'm not using Windows too often. Works OK on Ubuntu.

comment:6 Changed 14 years ago by marcopx

Locking is not permitted on windows. This is a WinGRASS problem.

comment:7 Changed 14 years ago by marcopx

Owner: changed from nobody to marcopx

comment:8 Changed 13 years ago by msieczka

Still applies under WINE 1.0.0 configured to emulate Win XP, on amd64 Debian testing, using Marco's "QGIS 0.11.0 for Windows pre-release testing installer".

I'm reporting the bug in GRASS Trac: http://trac.osgeo.org/grass/ticket/226.

comment:9 in reply to:  8 ; Changed 13 years ago by marcopx

Replying to msieczka:

Still applies under WINE 1.0.0 configured to emulate Win XP, on amd64 Debian testing, using Marco's "QGIS 0.11.0 for Windows pre-release testing installer".

I'm reporting the bug in GRASS Trac: http://trac.osgeo.org/grass/ticket/226.

I think that the bug could be fixed creating an empty .gislock file in the location's directory every time that location is opened.

Marco

comment:10 in reply to:  9 Changed 13 years ago by marcopx

Cc: jef@… added; neteler removed

Replying to marcopx:

Replying to msieczka:

Still applies under WINE 1.0.0 configured to emulate Win XP, on amd64 Debian testing, using Marco's "QGIS 0.11.0 for Windows pre-release testing installer".

I'm reporting the bug in GRASS Trac: http://trac.osgeo.org/grass/ticket/226.

I think that the bug could be fixed creating an empty .gislock file in the location's directory every time that location is opened.

Marco

Jurgen,

so you think that we could do that in one of the src\qgis-dev\src\plugins\grass\ cpp files?

Marco

comment:11 Changed 13 years ago by jef

Resolution: fixed
Status: newclosed

workaround in r9245: QGIS creates the lockfile by itself.

comment:12 Changed 13 years ago by jef

Cc: neteler added; jef@… removed

looks like Markus originally wanted to track this...

comment:13 in reply to:  11 ; Changed 13 years ago by marcopx

Resolution: fixed
Status: closedreopened

Replying to jef:

workaround in r9245: QGIS creates the lockfile by itself.

good, it works... but it generates another problem! if I close QGIS without closing the mapset the .gislock file is not deleted! thus, when I re-start QGIS and want to open the mapset, this is blocked because its .gislock file has not been deleted!

since locking is actually unsupported on windiws, we could just pass the "already exist check" on .gislock and just allow the user to open the mapset; what do you think?

Marco

comment:14 in reply to:  13 ; Changed 13 years ago by jef

Resolution: fixed
Status: reopenedclosed

Replying to marcopx:

Replying to jef: since locking is actually unsupported on windiws, we could just pass the "already exist check" on .gislock and just allow the user to open the mapset; what do you think?

That wasn't a windows problem. All plugins were not unloaded cleanly using their unload() method and therefore the mapset wasn't unlocked on all plattforms. Fixed in r9249

comment:15 in reply to:  14 Changed 13 years ago by marcopx

Replying to jef:

Replying to marcopx:

Replying to jef: since locking is actually unsupported on windiws, we could just pass the "already exist check" on .gislock and just allow the user to open the mapset; what do you think?

That wasn't a windows problem. All plugins were not unloaded cleanly using their unload() method and therefore the mapset wasn't unlocked on all plattforms. Fixed in r9249

cool! you did a great job ;) congrats Marco

comment:16 Changed 12 years ago by (none)

Milestone: Version 1.0.0

Milestone Version 1.0.0 deleted

Note: See TracTickets for help on using tickets.