Opened 9 years ago

Closed 9 years ago

#3467 closed bug (wontfix)

Label Buffers Produces Extremely Bloated PDF Export (Vector) under Linux.

Reported by: Thaddeus Owned by: mhugent
Priority: major: does not work as expected Milestone: Version 1.7.0
Component: Printing Version: Trunk
Keywords: Bloated PDF PostScript using Buffers Cc: mayeulk
Must Fix for Release: No Platform: Debian
Platform Version: Ubuntu 10.10 Awaiting user input: yes

Description

Simply by applying "Buffer Labels" to an 8-letter label on a vector layer containing a single-feature point creates more than a million (1314400 --corrupted PS) lines of PostScript? code that takes 5 minutes to display on a modern PC. Adding a few more features to label crashes Composer. The composer view used has just one item, a map object. This is under Ubuntu 10.10 and QGIS 1.6.

The attached example contains the QGS file, the point SHP file along with the malformed PDF printout.

Attachments (1)

BloatedPS.tar.gz (46.6 KB) - added by Thaddeus 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Thaddeus

Attachment: BloatedPS.tar.gz added

comment:1 Changed 9 years ago by Thaddeus

Keywords: Bloated using Buffers added; corruption removed
Summary: Extremely Bloated PDF Export (Vector) under Linux.Label Buffers Produces Extremely Bloated PDF Export (Vector) under Linux.

comment:2 Changed 9 years ago by mhugent

Awaiting user input: set

Is this with the old labeling engine (available through the vector property dialog) or with the new one (the abc-tool)?

comment:3 Changed 9 years ago by mayeulk

I' m looking at this

Mayeul

comment:4 Changed 9 years ago by mayeulk

Priority: critical: causes crash or data corruptionmajor: does not work as expected

Hi Marco,

This is with the old labeling engine (available through the vector property dialog).

When opening the qgis project in http://trac.osgeo.org/qgis/attachment/ticket/3467/BloatedPS.tar.gz I got "This project file was saved by an older version of QGIS. When saving this project file, QGIS will update it to the latest version, possibly rendering it useless for older versions of QGIS." (1.6.0 trunk). The project updated correctly to 1.7.

I can confirm the bug with several fonts (Ubuntu, Arial) at several scales, with the label engine which is available through the vector property dialog. The labelling-NG works perfectly.

Confirmed with following readers: Adobe Reader 9.4.2 (11 Febr 2011) and Okular (Kubuntu 10.10 64 bits). Okular is smarter than Adobe Reader (gives a low-resolution overview) but still takes 100% of one core for a while.

Hint to see the problem better: put a colored buffer. You'll see that the buffer is made of many displaced identical letters. The pdf file size is about 40 times bigger than with labelling -NG ( 307ko vs 7.7 ko).

I changed the priority as it does not crashes qgis; it produces corrupted (output) data but does not corrupt input data.

I guess should be fixed when labelling-NG will deprecates the old labelling engine.

Mayeul

comment:5 Changed 9 years ago by mayeulk

Cc: mayeulk added
Version: Trunk

comment:6 Changed 9 years ago by jef

Owner: changed from jef to mhugent

comment:7 Changed 9 years ago by mhugent

Resolution: wontfix
Status: newclosed

Hi Mayeul

Yes, it is because of the way how the old labeling engine draws buffers.

I'm setting the ticket to 'wontfix' because:

  • The behaviour of QGIS is not optimal. However, it is a bug of the pdf readers they cannot cope with a large number of features
  • A fix would involve to write a new logic for buffering in the old labeling engine. I believe nobody is available to invest time for something that will be removed shortly after 1.7
Note: See TracTickets for help on using tickets.