Opened 12 years ago

Closed 12 years ago

#3261 closed bug (fixed)

Rendering bug

Reported by: ccrook Owned by: nobody
Priority: major: does not work as expected Milestone: Version 1.7.0
Component: MapCanvas Version: Trunk
Keywords: render bug Cc:
Must Fix for Release: No Platform: Windows
Platform Version: XP Awaiting user input: no

Description

I've encountered a bug when viewing a line string layer which causes a large portion of the map canvas to be covered with the line colour when zoomed to a specific view. The data appears normallty when zooming in or out, or otherwise changing the canvas/view relationship.

I've attached a png screenshot and a zip file containing the QGIS project and spatialite database. Because the bug depends on the canvas size you may not be able to replicate immediately from this dataset. You should be able to infer the map canvas size from the screen shot.

This could be related to ticket 2915, which demonstrates a glitch plotting polygons.

Attachments (2)

render_bug.png (86.2 KB ) - added by ccrook 12 years ago.
Screenshot showing bug
render_bug.zip (9.4 KB ) - added by ccrook 12 years ago.
Project and data file

Download all attachments as: .zip

Change History (5)

by ccrook, 12 years ago

Attachment: render_bug.png added

Screenshot showing bug

by ccrook, 12 years ago

Attachment: render_bug.zip added

Project and data file

comment:1 by aghisla, 12 years ago

Can you give the spatial extent of the view, e.g. saving it as spatial bookmark?

Is it happening also on other platforms? As now, I can't reproduce it with QGIS r15724 on Fedora, but I'd wait for more info on the canvas extent.

comment:2 by gislab, 12 years ago

can't reproduce it as well on winXP r15700

in reply to:  2 comment:3 by ccrook, 12 years ago

Resolution: fixed
Status: newclosed

Replying to gislab:

can't reproduce it as well on winXP r15700

I can no longer reproduce the bug either (on 1.7.0). I'm guessing some other patches along the way have fixed it. I've reset the status to fixed.

Thanks for looking at it.

Note: See TracTickets for help on using tickets.