Ticket #2799 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

QGIS is painfully slow on large datasets!

Reported by: sandinog Owned by: nobody
Priority: major: does not work as expected Milestone: Version 1.6.0
Component: Build/Install Version: 1.4.0
Keywords: 'large dataset', speed Cc:
Platform Version: Platform: Windows
Must Fix for Release: No Awaiting user input: no

Description

I tried using QGIS with a fairly large dataset (all parcel polygons, roadway centerline lines, and street light points in Sacramento County, California (about 105 Mbytes of shapefiles, 155 Mbytes of attached database information). Every re-rendering took so much time! 1. It seems like the program is doing too much 'behind the scenes,' like it should use scale and the window size to re-render what the user can see, and not worry about what's off-screen, at least until a change of window coordinates (pan) or change of scale (zoom) is made.

2. I'm willing to upload the dataset I've been using (although the data owners don't really want the databases showing up all over the net), but given the size, I can hardly e-mail them.

Until the program can handle larger datasets, its going to remain a toy and a nice idea, but not a viable alternative to ArcGIS.

Change History

Changed 4 years ago by jef

  • status changed from new to closed
  • resolution set to duplicate

duplicate of #1978

Changed 4 years ago by lutra

Try use the "cache rendering" and also have a look here

 http://blog.qgis.org/node/144

hopefully the problem will be solved as late as by the end of the summer thanks to Martin D. and GSoC.

Note: See TracTickets for help on using tickets.