Opened 10 years ago

Closed 9 years ago

#2436 closed bug (wontfix)

New symbology print issue

Reported by: dr Owned by: nobody
Priority: major: does not work as expected Milestone: Version 1.7.0
Component: Printing Version: Trunk
Keywords: print, new symbology Cc: dr, gislab, alexbruy, neteler
Must Fix for Release: No Platform: All
Platform Version: Awaiting user input: no

Description

  1. Open any polygonal layer and set New symbology: "Funny fill" symbol style;
  2. If print this layer by internal QGIS pdf printer then all ok;
  3. If try to print it by external pdf printer or common printer - weg get bad result: http://gis-lab.info/share/DR/new_symbology_print.jpg. It's look like very small resolution image.

Attachments (2)

2436_pdf.png (182.0 KB) - added by medspx 10 years ago.
Image export of a PDF rendered map with funny fill under Evince !
2436.png (234.2 KB) - added by medspx 10 years ago.
Image export from QGis (print composer) with funny fill

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by wonder

I believe this scaling issue has been fixed few days ago. Please can you test again?

Martin

comment:2 Changed 10 years ago by medspx

The bug has not been fixed yet ! Furthermore, if I try to print via the internal PDF, the resolution of the fill texture is very low (the same than by printing on a printer).

The only "good" rendering is by using a PNG (image) export.

My tests have been done under Debian Squeeze with QGis 1.6.0 (r13939).

Changed 10 years ago by medspx

Attachment: 2436_pdf.png added

Image export of a PDF rendered map with funny fill under Evince !

Changed 10 years ago by medspx

Attachment: 2436.png added

Image export from QGis (print composer) with funny fill

comment:3 Changed 9 years ago by pcav

Milestone: Version 1.5.0Version 1.6.0

comment:4 Changed 9 years ago by zanollim

To simply reproduce this bug (1.6.0 trunk), try this:

  • open a simple polygon layer
  • use funny_fill to render it (note that the fill pattern is in pixel and NOT in map units, because if I zoom in/out, the squares of the pattern are redrawn in the map ALWAYS with the same size)
  • now open the print composer, choose for example A4 size and
    • export to PDF (or directly print) with option Print as raster CHECKED
    • export to PDF (or directly print) with option Print as raster UNCHECKED
  • note that both pdf documents are wrong and do not represent the original map shown in the print composer (the squares of funny fill are bigger or smaller than the expected result)

I think that this is a critical bug for printing

michele

comment:5 Changed 9 years ago by volter

It seems to me, the original problem is solved -- at least on Linux (r15333) and Qt 4.7.1.

But I can confirm what zanollim said.

comment:6 Changed 9 years ago by volter

Might be related to #3267.

comment:7 Changed 9 years ago by zanollim

Cc: neteler added

If I export a map to PDF with Print as raster option CHECKED (read my previous post) and I ONLY change the dpi quality, the results are all different (the dimension of the squares of funny fill depends on the dpi quality chosen) and this is not correct

comment:8 Changed 9 years ago by mhugent

Resolution: wontfix
Status: newclosed

The Qt fill styles are pixmaps, so impossible to render in good quality on all resolutions.

You could use the 'svg fill' symbollayer type. A solution for convenient creation of svg patterns (without using an svg editor by hand) is planned for this summer.

Regards, Marco

Note: See TracTickets for help on using tickets.