Opened 12 years ago

Closed 10 years ago

#1509 closed bug (fixed)

Polygon border color is not changed for selected polygons

Reported by: marisn Owned by: nobody
Priority: minor: annoyance Milestone: Version 1.5.0
Component: MapCanvas Version: Trunk
Keywords: Cc: pcav, dr
Must Fix for Release: No Platform: All
Platform Version: Awaiting user input: no

Description

If polygons are set to be displayed without fill, it's impossible to see which one is selected, as border color is not changed.

Attachments (1)

qgis_select_poly_bug.jpg (254.6 KB) - added by marisn 12 years ago.
How many rectangles are selected?

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by marisn

Attachment: qgis_select_poly_bug.jpg added

How many rectangles are selected?

comment:1 Changed 11 years ago by lutra

Cc: pcav added
Milestone: Version 1.0.3Version 1.2.0
Platform Version: Ubuntu 9.04
Version: 1.0.0HEAD

This is still a bug with QGis 1.2 (rev. 11005, Ubuntu 9.04).

comment:2 Changed 11 years ago by lutra

Component: SymbologyMapCanvas
Platform: GentooAll

comment:3 Changed 11 years ago by homann

It's made this way by deisgn, see #239. Perhaps another interior selectioncolor would be appropriate.

comment:4 in reply to:  3 Changed 11 years ago by lutra

Platform Version: Ubuntu 9.04

Replying to homann:

Perhaps another interior selectioncolor would be appropriate.

The problem is that changing the density of the fill color, it changes also the transparency/tone of the selection color. In the extreme case, with no fill color, the selection color is 100% transparent.

In general it seems that would be better to the selection color be always the same, otherwise the "selection color" option in "options --> general" loses its meaning.

comment:5 Changed 11 years ago by dr

Cc: dr added

confirmed

comment:6 Changed 10 years ago by wonder

Fixed for new symbology in r13322.

comment:7 Changed 10 years ago by lutra

Resolution: fixed
Status: newclosed

Well, if this has not been fixed for old symbology until now then I guess it will not be fixed in time when the new symbology will take over definitely.

Note: See TracTickets for help on using tickets.