Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1384 closed bug (fixed)

Ubuntu Intrepid GUI load failure

Reported by: wildintellect Owned by: wildintellect
Priority: critical: causes crash or data corruption Milestone:
Component: GUI Version: Trunk
Keywords: startup, intrepid, 8.10, ubuntu Cc:
Must Fix for Release: Yes Platform: Debian
Platform Version: Awaiting user input: no

Description

On upgrade from Ubuntu 8.04 to 8.10 qgis stops loading, the launcher gets stuck at 'Setting up GUI' strace and gdb indicate something to do with X. Along with QGIS lot's of other applications fail:

  • konquerer
  • qt designer
  • eric4
  • texmaker

The problem is actually a package that was upgrading during the dist-upgrade. It has yet to be identified but the list of potential bad packages is attached.

Plan is isolate the package and submit the issue to the appropriate developers. In the mean time we'll need to warn Intrepid users to remove the package.

Note: may not apply to all machines.

Attachments (3)

testpackages.txt (8.5 KB) - added by wildintellect 13 years ago.
Packages that need testing, to determine if they break qgis.
timpackages.txt (21.6 KB) - added by timlinux 13 years ago.
These are the packages installed on my system where QGIS will not run
petepackages-upgradejustfine.txt (24.3 KB) - added by ersts 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by wildintellect

Attachment: testpackages.txt added

Packages that need testing, to determine if they break qgis.

Changed 13 years ago by timlinux

Attachment: timpackages.txt added

These are the packages installed on my system where QGIS will not run

comment:1 Changed 13 years ago by timlinux

Must Fix for Release: NoYes

I've attached my package list for comparison. Although perhaps we need to have package version numbers factored into the mix...

Tim

Changed 13 years ago by ersts

comment:2 Changed 13 years ago by ersts

Here is my package list, my upgrade from 8.04 to 8.10 went just fine.

comment:3 Changed 13 years ago by timlinux

Resolution: fixed
Status: newclosed

This seems to be resolvable by doing:

sudo apt-get remove --purge libqt3-headers libqt3-mt libqt3-mt-dev uim-qt3

I believe specifically doing:

sudo apt-get remove --purge uim-qt3

should resolve the issue but needs to be verified.

comment:4 Changed 12 years ago by (none)

Milestone: Version 1.0.0

Milestone Version 1.0.0 deleted

Note: See TracTickets for help on using tickets.