Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#1025 closed bug (invalid)

segfault or error during splitting features

Reported by: msieczka Owned by: nobody
Priority: critical: causes crash or data corruption Milestone:
Component: Digitising Version: Trunk
Keywords: Cc:
Must Fix for Release: No Platform: Debian
Platform Version: Ubuntu Gutsy amd64 Awaiting user input: no

Description

I had a Shapefile, with only 1 single polygon. Tried to split it into 2 polgons with "split features tool". After marking the split line and pressing right mouse button QGIS (trunk r8309) crashed:

ERROR 1: Attempt to read shape with feature id (-3) out of available range.
Segmentation fault (core dumped)

Unfortunatelly I don't know how to reproduce the crash. The core file wasn't actually dumped. Thus sorry for no debug info.

Sometimes when splitting QGIS also pops up such an information window, but doesn't crash:

"An error occured during feature splitting"

Same as in case of the crash I can't find the pattern to reproduce it - it just sometimes happens. Maybe the 2 issues are connected.

Built and running against QT 4.3.2, Ubuntu Gutsy amd64.

Change History (6)

comment:1 Changed 12 years ago by msieczka

Milestone: Version 0.9.2

comment:2 Changed 12 years ago by jctull

I am also noticing the "An error occurred during feature splitting" dialog on polygon splits. Shapefile edits work in r8079, but are failing on many shapefiles in current SVN.

Additionally, I sometimes get no error message during polygon splits and no change to the polygon. There is no error output on my Console (OS X Leopard).

comment:3 Changed 12 years ago by msieczka

Still valid as of r8352.

comment:4 Changed 12 years ago by timlinux

Must Fix for Release: YesNo

Hi

I tried to replicate (using 8975) this using the polygon test data set under qgis/tests/testdata. I tried every permutation - single split line, multiple slice lines, spliting donut and multipart features and could not replicate.

In the absence of stacktrace or reliable way to replicate the issue, I'm going to remove the 'must fix' mark for this ticket. If more info comes to light please update the ticket and I will re-investigate. Alternatively close the ticket if you no longer can replicate - we can always re-open it if the problem resurfaces.

Regards

Tim

comment:5 Changed 12 years ago by homann

Resolution: invalid
Status: newclosed

Time to close this bug.

comment:6 Changed 11 years ago by (none)

Milestone: Version 1.0.0

Milestone Version 1.0.0 deleted

Note: See TracTickets for help on using tickets.