wiki:UsersWikiPostgreSQLPostGIS

Version 33 (modified by robe, 11 years ago) (diff)

--

Versions of PostgreSQL supported by which versions of PostGIS

PostgreSQL VersionPostGIS 1.3PostGIS 1.4PostGIS 1.5PostGIS 2.0 Trunk
7.2-7.4Yes (not windows)NoNoNo
8.0Yes (not windows)NoNoNo
8.1YesNoNoNo
8.2YesYesNoNo
8.3YesYesYesNo
8.4YesYesYesYes
9.0NoNoYesYes
9.1NoNoYes?Yes

For the question mark items Yes? support may be dropped for those before those products are officially released. Note we plan to drop support for PostgreSQL 8.3 in PostGIS 2.0. PostgreSQL 9.1 is now in development and PostgreSQL 9.0 is slated for release soon.

As a general rule, the PostGIS Project Steering committee tries to maintain support of PostGIS for at least two versions of PostgreSQL. We sometimes support more than 2 PostgreSQL versions, if requirements do not necessitate bumping up requirement without too much effort. We will rarely, if ever, support more than 3 PostgreSQL versions on any release.

We don't currently support 64-bit PostgreSQL Windows (which was introduced in PostgreSQL 9.0+).

Versions of GEOS support for PostGIS

The below chart shows which versions of GEOS work with which versions of PostGIS. The none means that you can get that version to work without GEOS, though its not recommended since a lot of functions will not be installed.

For the not recommended, this means that while you can get PostGIS to work with those versions, you'll be missing out on some PostGIS functions such as ST_Covers, ST_CoversBy and for PostGIS 1.5 the ST_HausdorffDistance and enhancements to ST_Buffer (both speed and functionality). GEOS 3.1 brought cascade union. GEOS 3.2 brought faster buffering and buffering enhancements, plus numerous enhancements with dealing with tolerance issues when unioning. GEOS 3.3 brought ST_ValidReason, ST_MakeValid etc (in the PostGIS 2.0 releases), so these functions will be disabled in PostGIS 2.0 if you are not running GEOS 3.3.

Geos VersionPostGIS 1.3PostGIS 1.4PostGIS 1.5PostGIS 2.0
NoneYes (not recommended)NoNo No
2.2Yes (not recommended)NoNo No
3.0YesYes (not recommended)No No
3.1YesYesYes (not recommended) (requires 3.1.1+) No
3.2YesYesYesYes (not recommended)
3.3YesYesYesYes