Changes between Version 92 and Version 93 of UsersWikiPostgreSQLPostGIS


Ignore:
Timestamp:
Nov 30, 2015, 11:19:09 AM (6 years ago)
Author:
robe
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • UsersWikiPostgreSQLPostGIS

    v92 v93  
    5757GEOS 3.4 introduced interruptibility features that allow you to cancel a query while in a GEOS loops.  Prior versions of PostGIS/GEOS a query could run (even with statement timeout) until you ran out of memory. This new feature requires both PostGIS 2.1 and GEOS 3.4+.  3.4 also brought [http://www.postgis.org/documentation/manual-svn/ST_DelaunayTriangles.html ST_DelaunayTriangles] so you won't get that in 2.1 if you don't compile for 3.4+.
    5858
    59 ||'''Geos Version'''||'''PostGIS 1.3'''||'''PostGIS 1.4'''||'''PostGIS 1.5'''||'''PostGIS 2.0'''||'''PostGIS 2.1'''||'''PostGIS 2.2'''
    60 ||'''None'''||Yes (not recommended)||No||No|| No|| No|| No
    61 ||'''2.2'''||Yes (not recommended)||No||No|| No|| No|| No
    62 ||'''3.0'''||Yes||Yes (not recommended)||No|| No|| No|| No
    63 ||'''3.1'''||Yes||Yes||Yes (not recommended) (requires 3.1.1+)|| No|| No|| No
    64 ||'''3.2'''||Yes||Yes||Yes||Yes (not recommended)|| No|| No
    65 ||'''3.3'''||Yes||Yes||Yes (preferred 3.3.3+)||Yes (3.3.9+)|| Yes (not recommended)|| Yes*
    66 ||'''3.4'''||Yes||Yes||Yes (preferred 3.4.2+)||Yes (3.4.2+)|| Yes|| Yes*
    67 ||'''3.5*'''||Yes||Yes||Yes ||Yes|| Yes|| Yes (recommended)
     59||'''Geos Version'''||'''PostGIS 1.3'''||'''PostGIS 1.4'''||'''PostGIS 1.5'''||'''PostGIS 2.0'''||'''PostGIS 2.1'''||'''PostGIS 2.2'''||'''PostGIS 2.3 Trunk'''
     60||'''None'''||Yes (not recommended)||No||No|| No|| No|| No|| No
     61||'''2.2'''||Yes (not recommended)||No||No|| No|| No|| No|| No
     62||'''3.0'''||Yes||Yes (not recommended)||No|| No|| No|| No|| No
     63||'''3.1'''||Yes||Yes||Yes (not recommended) (requires 3.1.1+)|| No|| No|| No|| No
     64||'''3.2'''||Yes||Yes||Yes||Yes (not recommended)|| No|| No|| No
     65||'''3.3'''||Yes||Yes||Yes (preferred 3.3.3+)||Yes (3.3.9+)|| Yes (not recommended)|| Yes*|| No*
     66||'''3.4'''||Yes||Yes||Yes (preferred 3.4.2+)||Yes (3.4.2+)|| Yes|| Yes*|| Yes*
     67||'''3.5*'''||Yes||Yes||Yes ||Yes|| Yes|| Yes (recommended) || Yes
    6868
    6969'''Versions of GDAL support for PostGIS'''