Changes between Version 11 and Version 12 of UsersWikiPostGIS20Debian60pkg


Ignore:
Timestamp:
Sep 28, 2012, 5:27:22 PM (10 years ago)
Author:
danielceregatti
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • UsersWikiPostGIS20Debian60pkg

    v11 v12  
    115115}}}
    116116
     117You'll have to add the backports repo  and pin the Postgres 9.1 packages to the "host" distro before installing the packages:
     118{{{
     119sudo bash -c "cat >> /etc/apt/sources.list.d/backports.list <<EOF
     120deb http://backports.debian.org/debian-backports squeeze-backports main
     121EOF
     122"
     123
     124sudo bash -c "cat >> /etc/apt/preferences.d/postgresql.pref <<EOF
     125Package: libpq5
     126Pin: release o=Debian Backports
     127Pin-Priority: 1000
     128
     129Package: libpq-dev
     130Pin: release o=Debian Backports
     131Pin-Priority: 1000
     132
     133Package: postgis
     134Pin: release o=Debian Backports
     135Pin-Priority: 1000
     136
     137Package: postgresql-9.1
     138Pin: release o=Debian Backports
     139Pin-Priority: 1000
     140
     141Package: postgresql-client-9.1
     142Pin: release o=Debian Backports
     143Pin-Priority: 1000
     144
     145Package: postgresql-client-common
     146Pin: release o=Debian Backports
     147Pin-Priority: 1000
     148
     149Package: postgresql-common
     150Pin: release o=Debian Backports
     151Pin-Priority: 1000
     152
     153Package: postgresql-contrib
     154Pin: release o=Debian Backports
     155Pin-Priority: 1000
     156
     157Package: postgresql-contrib-9.1
     158Pin: release o=Debian Backports
     159Pin-Priority: 1000
     160
     161Package: postgresql-plperl-9.1
     162Pin: release o=Debian Backports
     163Pin-Priority: 1000
     164
     165Package: postgresql-server-dev-9.1
     166Pin: release o=Debian Backports
     167Pin-Priority: 1000
     168EOF
     169"
     170
     171sudo apt-get update
     172}}}
    117173Install the pacakges. This command line would install all packages created by this process. Obviously don't pick anything you don't really need. For example, I have no use for the GEOS ruby bindings or the Postgis java package.
    118174{{{
     
    120176}}}
    121177
    122 Pull in deps
     178Pull in the new deps.
    123179{{{
    124180sudo apt-get -f install